Bug 1455346

Summary: Update python-idna to version 2.5
Product: [Community] RDO Reporter: Alan Pevec <apevec>
Component: distributionAssignee: Alan Pevec <apevec>
Status: CLOSED NOTABUG QA Contact: Shai Revivo <srevivo>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: trunkCC: amoralej, apevec, karlthered, markmc, mburns, npmccallum, nsoman, srevivo
Target Milestone: Milestone2Keywords: Rebase
Target Release: trunk   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-idna-2.5-1.el7 Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: 1455078 Environment:
Last Closed: 2017-06-02 13:20:42 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1427510    

Description Alan Pevec 2017-05-24 21:03:59 UTC
+++ This bug was initially created as a clone of Bug #1455078 +++

Description of problem:

Currently python-idna-2.0 is shipped in RHEL 7.3. This version consumes around 25MB of memory only to load:

>>> import resource
>>> resource.getrusage(resource.RUSAGE_SELF).ru_maxrss
5052
>>> import idna
>>> resource.getrusage(resource.RUSAGE_SELF).ru_maxrss
31344
>>> 

Some memory optimizations have been applied upstream from release 2.0 until latest one, 2.5 leading to a huge improvement:

>>> import resource
>>> resource.getrusage(resource.RUSAGE_SELF).ru_maxrss
5048
>>> import idna
>>> resource.getrusage(resource.RUSAGE_SELF).ru_maxrss
5888
>>> 

Reviewing the commits from v2.0..v2.5, there have been no changes in the public methods of the library, so it seems to be fully compatible with version 2.0, so i'd say it should be safe to update it.


OpenStack services using eventlet are using idna via import from python-dns, which is leading to increase memory usage.

Comment 1 Alan Pevec 2017-05-24 22:12:14 UTC
rebuilding latest 2.5 from Fedora with a small patch to disable py3:
https://github.com/rdo-common/python-idna/commit/183eb7316a0e0687c7224103d75d04f351072511

Comment 2 Alan Pevec 2017-05-24 22:27:34 UTC
Tagged for common-pending repo, please test if it is safe for common-testing.

Comment 5 Alan Pevec 2017-05-25 13:42:20 UTC
in common-testing

Comment 6 Haïkel Guémar 2017-06-02 13:20:42 UTC
Tagged in common-release since