Bug 1458351

Summary: Wacom Expresskeys Remote LED/Modes Become out of Sync with System
Product: Red Hat Enterprise Linux 7 Reporter: Michael Boisvert <mboisver>
Component: xorg-x11-drv-wacomAssignee: Peter Hutterer <peter.hutterer>
Status: CLOSED WONTFIX QA Contact: Desktop QE <desktop-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.4CC: arozansk, jkoten, mboisver, tpelka
Target Milestone: rc   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Known Issue
Doc Text:
The operating system always assumes Wacom Expresskeys Remote mode 1 when booting The Wacom Expresskeys Remote (EKR) is a standalone device and thus can be switched to any operating mode when the operating system (OS) boots. Currently, however, the OS always assumes that the EKR is set to mode 1 upon boot. Consequently, the EKR is not synchronized with the OS when the EKR mode was not set to 1 prior to system boot. To work around this problem, set the EKR to mode 1 before starting the OS.
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-03-07 05:22:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael Boisvert 2017-06-02 16:06:07 UTC
Description of problem: Because the EKR is a standalone device, the modes for the touchring can be switched without having your system on. Whatever mode the EKR is set to upon booting 7.4, the system assumes it is "mode 1." 

How reproducible: 100%

Steps to Reproduce:
1. Set EKR to mode 3 before booting 7.4.
2. Open Wacom Settings, select map buttons.
3. The map buttons GUI shows "mode 1" as the current mode even though the LED on the EKR is indicating "mode 3."

Actual results: Out of sync modes/leds.

Expected results: The system picks up whatever mode the EKR is in upon booting, or forces it to mode 1 once the driver is loaded.

Comment 5 Peter Hutterer 2017-09-28 04:45:48 UTC
Reassigning. libwacom is a descriptive library only, a wrapper around a bunch of text files. It doesn't change or query the tablet state at all. The xorg-x11-drv-wacom driver is at least in theory in control of the EKR

Comment 8 Red Hat Bugzilla Rules Engine 2018-03-07 05:22:03 UTC
Development Management has reviewed and declined this request. You may appeal this decision by reopening this request.