Bug 1459729

Summary: Compute resource for Openstack uses adminURL instead of publicURL for accessing Openstack
Product: Red Hat Satellite 6 Reporter: Graeme Gillies <ggillies>
Component: Compute Resources - OpenStackAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED DUPLICATE QA Contact: Katello QA List <katello-qa-list>
Severity: medium Docs Contact:
Priority: medium    
Version: 6.2.0CC: bbuckingham, dlobatog, ggillies, jcallaha
Target Milestone: UnspecifiedKeywords: Triaged
Target Release: UnusedFlags: dlobatog: needinfo? (ggillies)
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-22 16:01:11 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Graeme Gillies 2017-06-08 00:54:45 UTC
Description of problem:
When adding an openstack compute resource to Satellite, it will throw errors connecting to some Openstack resources (such as cinder) because it defaults to connecting to Openstack services on the adminURL instead of the publicURL. This is because the ruby fog library it uses defaults to adminURL. See

https://github.com/fog/fog-openstack/issues/234

This causes issues because by default, RHOS and RDO TripleO installations always put adminURLs on internal networks that aren't publicly accessible. This is valid because for most non-keystone services, the public and admin urls have the same functionality, and the adminURL is not needed.

Version-Release number of selected component (if applicable):
Satellite 6.2

How reproducible:
Reproducable easily with Satellite 6.2 against RHOS 11

Steps to Reproduce:
1. Do a standard RHOS 11 installation with TripleO
2. Configure compute provider in satellite to point to RHOS 11 installation
3. Attempt to create an instance backed onto a cinder volume

Actual results:
Get an error failing to connect to (cinder internal url)

Expected results:
instance is created successfully

Additional info:
We need to update

https://github.com/theforeman/foreman/blob/develop/app/models/compute_resources/foreman/model/openstack.rb#L187-L194

to expose the option openstack_endpoint_type to the user (or default it to publicURL)

Comment 3 Daniel Lobato Garcia 2017-11-22 16:01:11 UTC
This was fixed through projects.theforeman.org/issues/12054 - now we default to publicURL. 

Closing as POST and duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1513932 since the fix is the same.

*** This bug has been marked as a duplicate of bug 1513932 ***