Bug 1459994

Summary: [RFE][nova]: Netronome SmartNIC Enablement
Product: Red Hat OpenStack Reporter: Stephen Gordon <sgordon>
Component: openstack-novaAssignee: Stephen Finucane <stephenfin>
Status: CLOSED ERRATA QA Contact: Joe H. Rahme <jhakimra>
Severity: medium Docs Contact:
Priority: medium    
Version: 10.0 (Newton)CC: berrange, dasmith, eglynn, jschluet, kchamart, lyarwood, sbauza, sferdjao, sgordon, srevivo, stephenfin, vromanso
Target Milestone: Upstream M2Keywords: FutureFeature, OtherQA, Triaged
Target Release: 13.0 (Queens)Flags: jschluet: needinfo? (sgordon)
Hardware: Unspecified   
OS: Unspecified   
URL: https://blueprints.launchpad.net/nova/+spec/netronome-smartnic-enablement
Whiteboard:
Fixed In Version: openstack-nova-17.0.0-0.20180123163703.27eadbc.el7ost Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:31:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Stephen Gordon 2017-06-08 19:02:49 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/netronome-smartnic-enablement.

Description:

Netronome SmartNICs allow complex packet processing on the NIC. In order to
support hardware acceleration for them, Nova core needs modifications to
support the combination of VIF and OVS plugging they support. This spec
proposes a hybrid SR-IOV and OVS model to enable acceleration.

Specification URL (additional information):

https://specs.openstack.org/openstack/nova-specs/specs/pike/approved/netronome-smartnic-enablement.html

Comment 7 Jon Schlueter 2018-06-22 16:20:40 UTC
The content for this fix is included in OSP 13 RC which is available on the Red Hat OpenStack Platform beta channels currently.  Any efforts to verify that these bugs have been fixed would be appreciated.

Comment 9 errata-xmlrpc 2018-06-27 13:31:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086