Bug 1463439

Summary: [RFE] Hammer repository synchronize should give me the option to sync all repositories in an organization
Product: Red Hat Satellite 6 Reporter: Rich Jerrido <rjerrido>
Component: RepositoriesAssignee: satellite6-bugs <satellite6-bugs>
Status: CLOSED WONTFIX QA Contact: vijsingh
Severity: medium Docs Contact:
Priority: medium    
Version: 6.2.9CC: bkearney, cdonnell, dhlavacd, jcallaha
Target Milestone: UnspecifiedKeywords: FutureFeature
Target Release: Unused   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-28 19:35:19 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Rich Jerrido 2017-06-20 22:49:19 UTC
As a Satellite user, I have (on the sync status page) the ability to select ALL repositories and synchronize them. 

As a Satellite CLI user, I would like the ability to synchronize all repositories via a single hammer cli command so that I can better automate my workflow.

Something like the following would fit the bill nicely. 

hammer repository synchronize --all --organization Example

Comment 1 Marek Hulan 2017-06-21 08:29:24 UTC
Thanks for the report, we tend to use hammer component for things related to hammer core functionality, such as logging, authentication etc. Moving to repositories component to be triaged.

Comment 2 Bryan Kearney 2019-02-07 12:09:42 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 3 Bryan Kearney 2019-02-28 19:35:19 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.