Bug 1464966

Summary: [RFE]: Ceph cluster should not create any pools by default
Product: Red Hat Ceph Storage Reporter: John Spray <john.spray>
Component: RADOSAssignee: Josh Durgin <jdurgin>
Status: CLOSED ERRATA QA Contact: Vasishta <vashastr>
Severity: urgent Docs Contact: Erin Donnelly <edonnell>
Priority: urgent    
Version: 3.0CC: anharris, ceph-eng-bugs, dzafman, edonnell, hnallurv, jdurgin, kchai, kdreyer, vashastr
Target Milestone: rcKeywords: FutureFeature
Target Release: 3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: RHEL: ceph-12.2.0-1.el7cp Ubuntu: ceph_12.2.0-2redhat1xenial Doc Type: Bug Fix
Doc Text:
.Ceph no longer creates pools by default Previously, `rbd` pools were created by default upon Ceph cluster creation. This caused several problems, including unnecessary health warnings. Pools are now created only by the user based on their needs rather than by default.
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-05 23:34:34 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1494421    

Description John Spray 2017-06-26 10:11:47 UTC
Currently, we auto-create the 'rbd' pool when a cluster is created.

There are a few problems with this:
 * We can't sanely guess the pg num at this point, and users will try and use the pool with a silly small pg num.
 * The user may not even want rbd.
 * The pool may be created before there are any OSDs leading to awkward health warnings about inability to create its pgs

The solution is not to create any pools by default -- pool creation must be a guided thing depending on what the user wants to use the cluster for.

This may break some tools/tests that expected there to always be at least one pool, or which expected that the rbd pool would always be there.

Comment 4 Josh Durgin 2017-08-30 17:46:38 UTC
https://github.com/ceph/ceph/pull/15894

Comment 6 Vasishta 2017-09-12 14:56:56 UTC
I observed that there were no pools created by default. I even observed that when a RGW daemon was added, rgw-data pool was created only when IOs were started.
Moving to VERIFIED state

$ sudo ceph -s --cluster 12_luminous
  cluster:
    id:     34652d30-4cf9-432c-b7df-da63395422eb
    health: HEALTH_OK
 
  services:
    mon: 1 daemons, quorum magna097
    mgr: magna097(active)
    osd: 9 osds: 9 up, 9 in
 
  data:
    pools:   0 pools, 0 pgs
    objects: 0 objects, 0 bytes
    usage:   0 kB used, 0 kB / 0 kB avail
    pgs:     

Regards,
Vasishta

Comment 11 errata-xmlrpc 2017-12-05 23:34:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387