Bug 1466000

Summary: [RFE][cinder] Add per-backend availability zones
Product: Red Hat OpenStack Reporter: Bertrand <brault>
Component: openstack-cinderAssignee: Gorka Eguileor <geguileo>
Status: CLOSED ERRATA QA Contact: Avi Avraham <aavraham>
Severity: medium Docs Contact:
Priority: high    
Version: 12.0 (Pike)CC: abdelhadi.chari, cschwede, ecv-redhat, eharney, gcharot, geguileo, knylande, scohen, sputhenp, srevivo, tshefi
Target Milestone: Upstream M1Keywords: FutureFeature, TestOnly, Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
URL: https://blueprints.launchpad.net/cinder/+spec/multibackend-az-support
Whiteboard:
Fixed In Version: openstack-cinder-12.0.0-0.20171206135420.61962d2.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:31:39 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1419948, 1452704, 1459148, 1488390, 1510931    

Description Bertrand 2017-06-28 16:44:15 UTC
Description of problem:


When volume backends were defined in the [DEFAULT] cinder.conf config
section, it did not make sense to have more than one AZ config setting.
Now that we have multibackend and we have deprecated the ability to
configure backends in DEFAULT, we can set AZs per backend section.

This previously required setting up a separate service using a different
cinder.conf to have more than one AZ. But since the vast majority of
backends are separate physical devices, there is no reason to restrict
the control plane service to be on separate nodes to support separate AZ
configurations.

[1] https://blueprints.launchpad.net/cinder/+spec/multibackend-az-support
[2] https://review.openstack.org/#/c/433437/

Comment 6 Avi Avraham 2018-04-03 12:38:42 UTC
Verified with package: 
openstack-cinder-12.0.1-0.20180326201852.46c4ec1.el7ost.noarch
according to Polarion test run:
20180206-1636_2 - [cinder] volume per-backend availability zones RHOS13

Comment 9 errata-xmlrpc 2018-06-27 13:31:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086