Bug 1466678

Summary: RFE: backport weak dependency tags to RHEL6 rpm
Product: Red Hat Enterprise Linux 6 Reporter: Tomas Lestach <tlestach>
Component: rpmAssignee: packaging-team-maint
Status: CLOSED ERRATA QA Contact: Eva Mrakova <emrakova>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 6.10CC: dmach, emrakova, ggainey, ignatenko, ksrot, mmraka, msuchy, pmatilai, riehecky, rwilliam, salmy, tbowling, tlestach
Target Milestone: rcKeywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: rpm-4.8.0-56.el6 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1508538 (view as bug list) Environment:
Last Closed: 2018-06-19 01:20:53 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1494486, 1494504, 1508538    
Attachments:
Description Flags
reading weak/rich deps on RHEL 6 none

Comment 7 Daniel Mach 2017-08-22 08:37 EDT
Created attachment 1316617 [details]
reading weak/rich deps on RHEL 6

I've put together code that demonstrates that weak/rich deps are readable on RHEL 6 with existing RPM.
As Panu mentioned, it's all about the constants or knowing the IDs if RPM doesn't provide the constants.
Comment 44 errata-xmlrpc 2018-06-19 01:20:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1909