Bug 1467220

Summary: [Mellanox Pike FEAT] openvswitch: update package
Product: Red Hat OpenStack Reporter: Slava Shwartsman <sshwarts>
Component: openvswitchAssignee: Flavio Leitner <fleitner>
Status: CLOSED DUPLICATE QA Contact: Ofer Blaut <oblaut>
Severity: medium Docs Contact:
Priority: medium    
Version: 12.0 (Pike)CC: aloughla, amuller, apevec, chrisw, rhos-maint, sgordon, srevivo
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1468331 (view as bug list) Environment:
Last Closed: 2017-07-14 19:19:43 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Slava Shwartsman 2017-07-03 07:49:37 UTC
1. Feature Overview:
        a) Name of feature:
                Update openvswitch package
        b) Feature description:
                This feature request is for update the openvswitch package to include the latest bug fixes and features.
                We would like to update the openvswitch package to v2.8.0 to include the HW offload support for openvswitch patches.

2. Feature Details:
        a) Architectures:
                x86_64, ppc64le, ppc64, aarch64
        b) Bugzilla dependencies:
        c) Drivers or hardware dependencies:
                bash
                coreutils
                glibc
                iproute
                kmod
                openssl
                openssl-libs
                python
        d) Upstream acceptance information:
        e) External links:
        f) Severity (H, M, L):
                High
        g) Feature needed by:
                Partner: Mellanox

3. Business Justification:
        a) why is this feature needed?
        b) What hardware does this enable?
        c) Business impact?
        d) Other business drivers?

4. Primary contact at Red Hat, email, phone (chat):
        Andre Beausoleil abeausol@redhat.com

5. Primary contact at Partner, email. phone (chat):
        Kamal Heib kheib@redhat.com, Slava Shwartsman sshwarts@redhat.com, Noa Spanier noas@mellanox.com

Comment 1 Slava Shwartsman 2017-07-03 10:18:40 UTC
We need this patch-set:
https://lists.linux-foundation.org/pipermail/ovs-dev/2017-June/333630.html

Comment 2 Assaf Muller 2017-07-14 19:19:43 UTC
We are expected to update OVS to 2.8 in OSP 13, but not sooner.

*** This bug has been marked as a duplicate of bug 1468331 ***