Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.

Bug 1467277

Summary: [GSS] [RFE] add documentation on --xml and --mode=script options to gluster interactive help and man pages
Product: [Community] GlusterFS Reporter: Gaurav Yadav <gyadav>
Component: cliAssignee: Gaurav Yadav <gyadav>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: low    
Version: mainlineCC: amukherj, bkunal, bsrirama, pousley, psony, rhs-bugs, sasundar, storage-qa-internal
Target Milestone: ---Keywords: FutureFeature, ZStream
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: glusterfs-3.12.0 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1404872 Environment:
Last Closed: 2017-09-05 13:35:44 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1404872    

Comment 1 Atin Mukherjee 2017-07-04 00:48:11 EDT
What is the nature and description of the request?

The customer has requested that documentation regarding options for XML output and script mode (non interactive shell mode) be added to gluster man pages and help. 

They have also stated that there may be other options that they are unaware of which could also be added to gluster help and man pages.
Comment 2 Worker Ant 2017-07-04 22:33:46 EDT
REVIEW: https://review.gluster.org/17685 (gluster man page: Add output option "--mode=script" and modify "--xml" to man page of gluster) posted (#3) for review on master by Gaurav Yadav (gyadav@redhat.com)
Comment 3 Worker Ant 2017-07-05 00:18:46 EDT
REVIEW: https://review.gluster.org/17685 (gluster man page: Modify output option "--mode=script" and modify "--xml" to man page of gluster) posted (#4) for review on master by Gaurav Yadav (gyadav@redhat.com)
Comment 4 Worker Ant 2017-07-05 02:09:37 EDT
REVIEW: https://review.gluster.org/17685 (gluster man page: Modify output option "--mode=script" and modify "--xml" to man page of gluster) posted (#5) for review on master by Gaurav Yadav (gyadav@redhat.com)
Comment 5 Worker Ant 2017-07-05 05:16:24 EDT
REVIEW: https://review.gluster.org/17685 (gluster man page: Modify output option "--mode=script" and modify "--xml" to man page of gluster) posted (#6) for review on master by Gaurav Yadav (gyadav@redhat.com)
Comment 6 Worker Ant 2017-07-10 12:08:53 EDT
REVIEW: https://review.gluster.org/17685 (gluster man page: Add  remote-host and mode=script output option to man                   page of gluster) posted (#7) for review on master by Gaurav Yadav (gyadav@redhat.com)
Comment 7 Worker Ant 2017-07-10 14:55:47 EDT
REVIEW: https://review.gluster.org/17685 (gluster man page: Modify output option "--mode=script" and modify "--xml" to man page of gluster) posted (#8) for review on master by Gaurav Yadav (gyadav@redhat.com)
Comment 8 Worker Ant 2017-07-10 21:46:04 EDT
REVIEW: https://review.gluster.org/17685 (gluster man page: Add remote-host and mode=script output option to                   man page of gluster) posted (#9) for review on master by Gaurav Yadav (gyadav@redhat.com)
Comment 9 Worker Ant 2017-07-10 23:46:08 EDT
REVIEW: https://review.gluster.org/17685 (gluster man page: Add remote-host and mode=script output option to                   man page of gluster) posted (#10) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 10 Worker Ant 2017-07-11 08:46:57 EDT
REVIEW: https://review.gluster.org/17685 (gluster man page: Add remote-host and script mode in gluster man page) posted (#11) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 11 Worker Ant 2017-07-11 09:00:03 EDT
COMMIT: https://review.gluster.org/17685 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 09f9c6c1c9c565d54c257e58c46004326ec1c495
Author: Gaurav Yadav <gyadav@redhat.com>
Date:   Tue Jul 4 11:18:16 2017 +0530

    gluster man page: Add remote-host and script mode in gluster man page
    
    Signed-off-by: Gaurav Yadav <gyadav@redhat.com>
    Change-Id: I2d9b9f09d72d713e34ccb9516387c5982b830115
    BUG: 1467277
    Reviewed-on: https://review.gluster.org/17685
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 12 Shyamsundar 2017-09-05 13:35:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/