Bug 1467945

Summary: Deployment fails when setting the OpenDaylight controller password using OpenDaylightPassword
Product: Red Hat OpenStack Reporter: Itzik Brown <itbrown>
Component: openstack-tripleo-heat-templatesAssignee: Tim Rozet <trozet>
Status: CLOSED ERRATA QA Contact: Itzik Brown <itbrown>
Severity: high Docs Contact:
Priority: high    
Version: 12.0 (Pike)CC: jjoyce, jschluet, lpeer, mburns, nyechiel, rhel-osp-director-maint, slinaber, trozet, tvignaud
Target Milestone: Upstream M3Keywords: Triaged
Target Release: 12.0 (Pike)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-7.0.0-0.20170721174554.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
N/A
Last Closed: 2017-12-13 21:39:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Itzik Brown 2017-07-05 14:57:59 UTC
Description of problem:
When setting a value for OpenDaylightPassword parameter the deployment fails:
    Error: curl -o /dev/null --fail --silent --head -u admin:admin http://172.17.1.10:8081/restconf/operational/network-topology:network-topology/topology/netvirt:1 returned 22 instead of one of [0]
    Error: /Stage[main]/Neutron::Plugins::Ovs::Opendaylight/Exec[Wait for NetVirt OVSDB to come up]/returns: change from notrun to 0 failed: curl -o /dev/null --fail --silent --head -u admin:admin http://172.17.1.10:8081/restconf/operational/network-topology:network-topology/topology/netvirt:1 returned 22 instead of one of [0]

Version-Release number of selected component (if applicable):
puppet-tripleo-7.1.1-0.20170623015402.2625756.el7ost.noarch
puppet-opendaylight-4.0.1-0.20170623221955.e3f8182.el7ost.noarch
opendaylight-6.0.0-1.el7.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Itzik Brown 2017-08-06 12:21:39 UTC
Verified with:
openstack-tripleo-heat-templates-7.0.0-0.20170721174554.el7ost.noarch

Comment 6 errata-xmlrpc 2017-12-13 21:39:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462