Bug 1471054

Summary: MIssing dependencies
Product: [Fedora] Fedora EPEL Reporter: Bart Vanbrabant <bart>
Component: python-winrmAssignee: Orphan Owner <extras-orphan>
Status: NEW --- QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: epel7CC: athmanem, james.hogarth, orion
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Bart Vanbrabant 2017-07-14 10:19:05 UTC
Description of problem:
winrm depends on python-requests. However in its requirements it specifies that this version needs to be >= 2.9.1 The rpm available in for requests is 2.6.0

Python scripts function but if the use entrypoints pkg_resources will check these dependencies and fail:

Traceback (most recent call last):
  File "/usr/bin/twin", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 3011, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 626, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: requests>=2.9.1

Version-Release number of selected component (if applicable):
latest

How reproducible:
create a script that uses entrypoints and depends on winrm

Steps to Reproduce:
1. execute the script

Actual results:
Traceback (most recent call last):
  File "/usr/bin/twin", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 3011, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 626, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: requests>=2.9.1

Expected results:
$? == 0

Additional info:

Comment 1 Orion Poplawski 2017-09-14 20:21:06 UTC
Likewise for kerberos:

[kerberos]
requests-kerberos>=0.10.0

But the version in epel is 0.7.0.2.  Trying to use it with ansible will result in an error like:

hostname.domain.com | UNREACHABLE! => {
    "changed": false,
    "msg": "kerberos: __init__() got an unexpected keyword argument 'hostname_override'",
    "unreachable": true
}

Comment 2 Fedora Admin user for bugzilla script actions 2021-01-05 15:53:02 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 3 Fedora Admin user for bugzilla script actions 2021-01-12 12:06:54 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 4 Igor Raits 2021-01-12 12:10:02 UTC
If there is anybody to step up on maintaining this package in EPEL, I'll happily add one as a co-maintainer.

Comment 5 Fedora Admin user for bugzilla script actions 2021-01-12 14:54:26 UTC
This package has changed maintainer in the Fedora.
Reassigning to the new maintainer of this component.

Comment 6 Orion Poplawski 2021-03-02 17:47:52 UTC
Igor - please add me (orion) as co-maintainer.  Thanks.