Bug 1472363

Summary: [RFE] Change the default API version used by the client to the latest
Product: Red Hat OpenStack Reporter: Dmitry Tantsur <dtantsur>
Component: python-ironicclientAssignee: Dmitry Tantsur <dtantsur>
Status: CLOSED ERRATA QA Contact: mlammon
Severity: medium Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: apevec, bfournie, jschluet, lhh, mburns, racedoro, rhel-osp-director-maint
Target Milestone: Upstream M2Keywords: FutureFeature, Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
URL: http://specs.openstack.org/openstack/ironic-specs/specs/not-implemented/cli-default-api-version.html
Whiteboard:
Fixed In Version: python-ironicclient-2.2.0-1.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:32:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1473267    

Description Dmitry Tantsur 2017-07-18 14:49:00 UTC
It's very inconvenient that we have to provide --os-baremetal-api-version flag every time we use a new version. An error message due to not doing it can also be quite not clear. We have decided on the Pike PTG that we will change the default version from the lowest supported to the highest supported.

No direct impact on TripleO, as it pins the version. We can unpin it for the overcloud.

Comment 5 Dmitry Tantsur 2018-03-29 13:06:24 UTC
Testing PASSED on RHEL 7.5, puddle 2018-03-29.1. Notes:

$ export OS_BAREMETAL_API_VERSION=1.1
$ openstack baremetal node trait list host08
Requested API version 1.1 is not supported by the server, client, or
the requested operation is not supported by the requested
version.Supported version range is 1.1 to 1.37
$ unset OS_BAREMETAL_API_VERSION
$ openstack baremetal node trait list host08
$

Comment 7 errata-xmlrpc 2018-06-27 13:32:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086