Bug 1472985

Summary: python-mysql lacks the mysql_real_escape_string_quote symbol
Product: [Fedora] Fedora Reporter: David Hill <dhill>
Component: python-mysqlAssignee: Jakub Dorňák <jakub.dornak>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dhill, gary.buhrmaster, hobbes1069, jakub.dornak
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
See Also: https://code.mythtv.org/trac/ticket/13093
Whiteboard:
Fixed In Version: python-mysql-1.3.12-1.fc26 python-mysql-1.3.12-1.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-09-12 22:56:50 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description David Hill 2017-07-19 18:06:15 UTC
Description of problem:
Traceback (most recent call last):
  File "sync_musicbrainz.py", line 3, in <module>
    import MySQLdb
  File "/usr/lib64/python2.7/site-packages/MySQLdb/__init__.py", line 19, in <module>
    import _mysql
ImportError: /usr/lib64/python2.7/site-packages/_mysql.so: undefined symbol: mysql_real_escape_string_quote


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 David Hill 2017-07-19 18:06:30 UTC
python2-mysql-1.3.10-2.fc27.x86_64

Comment 2 David Hill 2017-07-19 18:08:31 UTC
python2-mysql-1.3.7-7.fc26.x86_64 still had it

Comment 3 Gary Buhrmaster 2017-08-09 16:07:12 UTC
Looks like resolved with upstream commit 4202f61 related to issue #115

refs:

https://github.com/PyMySQL/mysqlclient-python/commit/4202f611df07ae1274e7f0d71677cfd4cd778084

https://github.com/PyMySQL/mysqlclient-python/pull/115

Comment 4 Jan Kurik 2017-08-15 08:27:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.

Comment 5 Richard Shaw 2017-09-03 12:51:50 UTC
Still a problem for rawhide.

Comment 6 Richard Shaw 2017-09-03 13:50:50 UTC
python-mysql 1.3.10 has this commit from pull 115 referenced above but importing the python module still fails with the same error:

$ python
Python 2.7.13 (default, Jun 26 2017, 10:16:32) 
[GCC 7.1.1 20170526 (Red Hat 7.1.1-2)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import MySQLdb
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/MySQLdb/__init__.py", line 19, in <module>
    import _mysql
ImportError: /usr/lib64/python2.7/site-packages/_mysql.so: undefined symbol: mysql_real_escape_string_quote

Comment 7 Jakub Dorňák 2017-09-03 22:26:00 UTC
I've just upgraded python-mysql to 1.3.12, which slightly improves the commit above:
https://github.com/PyMySQL/mysqlclient-python/commit/6058715077d7b63599eefd6eb8460548cba7c951

And it seems to work.

Comment 8 Richard Shaw 2017-09-04 12:29:25 UTC
Since I'm not currently a maintainer for this package I'm reluctant to upgrade the version but I did try a scratch build:

https://koji.fedoraproject.org/koji/taskinfo?taskID=21646244

I also had to add a workaround because my_config.h was moved in Fedora 27.

I also emailed the package maintainers a few weeks ago and haven't gotten a response so at this point I'm assuming it's OK to make the required updates.

Comment 9 Richard Shaw 2017-09-04 12:32:17 UTC
Well, now it looks like Jakub has updated the package yesterday, but only for rawhide. This needs to be propagated to at least f26.

Comment 10 Jakub Dorňák 2017-09-04 12:42:25 UTC
I first wanted to ensure, that it helps.
(Going to rebase f26 and f27 too.)

Comment 11 Fedora Update System 2017-09-04 13:35:04 UTC
python-mysql-1.3.12-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-9b948d6e91

Comment 12 Fedora Update System 2017-09-04 13:35:56 UTC
python-mysql-1.3.12-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-992d36c1a5

Comment 13 Fedora Update System 2017-09-04 22:50:49 UTC
python-mysql-1.3.12-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-9b948d6e91

Comment 14 Fedora Update System 2017-09-04 22:53:39 UTC
python-mysql-1.3.12-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-992d36c1a5

Comment 15 Fedora Update System 2017-09-12 22:56:50 UTC
python-mysql-1.3.12-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2017-09-30 06:15:55 UTC
python-mysql-1.3.12-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.