Bug 1474008

Summary: SELinux is preventing sssd from read, write access on the file cache_implicit_files.ldb.
Product: [Fedora] Fedora Reporter: Thomas Drake-Brockman <thom>
Component: selinux-policyAssignee: Lukas Vrabec <lvrabec>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 26CC: dominick.grift, dwalsh, lsm5, lvrabec, mgrepl, plautrba, pmoore, ssekidde
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:f9240d3707379c8bfcdcd685b47bc9f7742781b90c58a2b9dd4dd13fc50bb422;VARIANT_ID=workstation;
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-02-26 15:58:38 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Thomas Drake-Brockman 2017-07-23 05:34:25 UTC
Description of problem:
SELinux is preventing sssd from read, write access on the file cache_implicit_files.ldb.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that sssd should be allowed read write access on the cache_implicit_files.ldb file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'sssd' --raw | audit2allow -M my-sssd
# semodule -X 300 -i my-sssd.pp

Additional Information:
Source Context                system_u:system_r:sssd_t:s0
Target Context                system_u:object_r:unlabeled_t:s0
Target Objects                cache_implicit_files.ldb [ file ]
Source                        sssd
Source Path                   sssd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-260.1.fc26.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.11.10-300.fc26.x86_64 #1 SMP Wed
                              Jul 12 17:05:39 UTC 2017 x86_64 x86_64
Alert Count                   2
First Seen                    2017-07-22 22:29:37 AWST
Last Seen                     2017-07-22 22:46:51 AWST
Local ID                      265835b0-e791-4a92-85d9-f721b90f191d

Raw Audit Messages
type=AVC msg=audit(1500734811.963:101): avc:  denied  { read write } for  pid=742 comm="sssd" name="cache_implicit_files.ldb" dev="nvme0n1p4" ino=155680 scontext=system_u:system_r:sssd_t:s0 tcontext=system_u:object_r:unlabeled_t:s0 tclass=file permissive=0


Hash: sssd,sssd_t,unlabeled_t,file,read,write

Version-Release number of selected component:
selinux-policy-3.13.1-260.1.fc26.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.1
hashmarkername: setroubleshoot
kernel:         4.11.10-300.fc26.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2018-02-26 15:58:38 UTC

*** This bug has been marked as a duplicate of bug 1546536 ***