Bug 1474100

Summary: Use of uninitialized value in string ne at /usr/bin/logconv.pl
Product: Red Hat Enterprise Linux 7 Reporter: Viktor Ashirov <vashirov>
Component: 389-ds-baseAssignee: mreynolds
Status: CLOSED ERRATA QA Contact: Viktor Ashirov <vashirov>
Severity: low Docs Contact:
Priority: low    
Version: 7.4CC: nkinder, rmeggins, sigbjorn
Target Milestone: rc   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 389-ds-base-1.3.7.5-7.el7 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-04-10 10:18:12 EDT Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Viktor Ashirov 2017-07-23 17:19:54 EDT
Description of problem:
The following snippet from access log produces error before outputting log stats:

[23/Jul/2017:22:04:38.941421026 +0200] conn=26261 fd=121 slot=121 connection from 192.168.88.6 to 192.168.88.6
[23/Jul/2017:22:04:38.941527375 +0200] conn=26261 op=0 BIND dn="cn=Directory Manager" method=128 version=3
[23/Jul/2017:22:04:38.941603992 +0200] conn=26261 op=0 RESULT err=0 tag=97 nentries=0 etime=0 dn="cn=directory manager"
[23/Jul/2017:22:04:38.941695466 +0200] conn=26261 op=1 UNBIND
[23/Jul/2017:22:04:38.941709197 +0200] conn=26261 op=1 fd=121 closed - U1

Use of uninitialized value in string ne at /usr/bin/logconv.pl line 2565, <$LOGFH> line 4


Version-Release number of selected component (if applicable):
389-ds-base-1.3.6.1-16.el7.x86_64

Additional info:
Regression was introduced in a fix for https://bugzilla.redhat.com/show_bug.cgi?id=1111400, upstream: https://pagure.io/389-ds-base/issue/48681
Comment 5 Viktor Ashirov 2017-11-06 08:47:38 EST
Build tested:
389-ds-base-1.3.7.5-9.el7

No errors in the output, marking as VERIFIED.
Comment 8 errata-xmlrpc 2018-04-10 10:18:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0811