Bug 1475554

Summary: [RFE] Creating a new role (osd+mon+nova compute on same node)
Product: Red Hat OpenStack Reporter: jomurphy
Component: openstack-tripleo-heat-templatesAssignee: John Fulton <johfulto>
Status: CLOSED ERRATA QA Contact: Yogev Rabl <yrabl>
Severity: high Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: brault, dbecker, flucifre, gcharot, gfidente, jefbrown, johfulto, mburns, morazi, rhel-osp-director-maint, sclewis, scohen
Target Milestone: Upstream M2Keywords: FutureFeature, Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20171206151028.97e841d.el7ost Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1539034 (view as bug list) Environment:
Last Closed: 2018-06-27 13:33:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1659607, 1459148, 1475550, 1539034, 1659608    

Description jomurphy 2017-07-26 21:27:55 UTC

Comment 4 John Fulton 2017-11-15 15:32:56 UTC
Today a customer can set up HCI with Mons on the controller easily by running:

openstack overcloud roles generate -o /home/stack/roles_data.yaml Controller ComputeHCI 

This is basically a request for the user to be able to run something like:

openstack overcloud roles generate -o /home/stack/roles_data.yaml ControllerSansMon ComputeMonHCI ComputeHCI

and they'd get some Compute+OSDs+Mons and some Compute+OSDs and controller nodes without the Ceph monitor service. 

I'll need to make updates so that `openstack overcloud role list` returns the new ControllerSansMon and ComputeMonHCI roles.

Comment 9 Yogev Rabl 2018-04-13 13:54:16 UTC
Verified on openstack-tripleo-heat-templates-8.0.2-0.20180327213843.f25e2d8.el7ost.noarch

Comment 11 errata-xmlrpc 2018-06-27 13:33:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086