Bug 1475859

Summary: [RFE] Add parallelism in radosgw-admin bucket rm command for bucket removal including S3/Swift API bucket rm calls
Product: Red Hat Ceph Storage Reporter: Vikhyat Umrao <vumrao>
Component: RGWAssignee: Matt Benjamin (redhat) <mbenjamin>
Status: CLOSED DEFERRED QA Contact: Tejas <tchandra>
Severity: medium Docs Contact:
Priority: high    
Version: 2.3CC: cbodley, ceph-eng-bugs, hgurav, hklein, hnallurv, karan, kbader, mbenjamin, mhackett, sweil, tpetr
Target Milestone: rcKeywords: FutureFeature
Target Release: 5.0   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-07-01 15:29:09 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1727980    

Description Vikhyat Umrao 2017-07-27 13:33:03 UTC
Description of problem:
[RFE] Add parallelism  in radosgw-admin bucket rm command for bucket removal

Customers/users are still reporting that bucket removal is slow with --bypass-gc and --inconsistent-index flags used:

radosgw-admin bucket rm --purge-objects --bypass-gc --inconsistent-index --bucket=<bucket name>


Version-Release number of selected component (if applicable):
Red Hat Ceph Storage 2.y

Comment 1 Vikhyat Umrao 2017-07-27 13:37:26 UTC
If we use --inconsistent-index and close the interrupt this command because of performance issue or some other reason we will have corrupted index and next time it will not allow deleting the bucket due to corrupted index then we need to run radosgw-admin bucket check --fix.

Comment 8 Vikhyat Umrao 2019-01-25 20:02:09 UTC
*** Bug 1667236 has been marked as a duplicate of this bug. ***

Comment 11 Giridhar Ramaraju 2019-08-05 13:06:01 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 12 Giridhar Ramaraju 2019-08-05 13:08:44 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri