Bug 1481220

Summary: [RFE] Request to add a smart check for "yum clean all" command (in RHEL 7.4) for the disabled repositories before displaying warning message
Product: Red Hat Enterprise Linux 7 Reporter: paygupta
Component: yumAssignee: Michal Domonkos <mdomonko>
Status: CLOSED ERRATA QA Contact: Eva Mrakova <emrakova>
Severity: medium Docs Contact: Marie Hornickova <mdolezel>
Priority: medium    
Version: 7.4CC: emrakova, james.antill, mdomonko, tbowling, udayendu.kar, vvasilev
Target Milestone: rcKeywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: yum-3.4.3-160.el7 Doc Type: Release Note
Doc Text:
The `yum clean all` command now prints a disk usage summary When using the "yum clean all" command, the following hint was always displayed: Maybe you want: rm -rf /var/cache/yum With this update, the hint has been removed, and "yum clean all" now prints a disk usage summary for remaining repositories that were not affected by "yum clean all"
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-30 11:40:23 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description paygupta 2017-08-14 11:55:41 UTC
1. Proposed title of this feature request

Request to add a smart check for "yum clean all" command (in RHEL 7.4) for the disabled repositories before displaying warning message.

2. What is the nature and description of the request?

In RHEL 7.4 # yum clean all command is shows a warning message "Maybe you want: rm -rf /var/cache/yum, to also free up space taken by orphaned data from disabled or removed repos" every time even if there are no disabled repos consuming disk space for its repodata. This change was implemented as a part of bugzilla : 1357083


4. Why does the customer need this? (List the business requirements here)

The warning message is not user friendly for normal users (developers), users get confused with the warning. This warning is displayed even if the system is not registered to the customer portal and using only local repositories.

5. How would the customer like to achieve this? (List the functional requirements here)

# yum clean all command should check the enabled vs disabled repositories and if there is significant amount of space consumed by the disabled repositories then only the warning message should be displayed on the console to clean the disk space consumed by the disabled repositories. 

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.

Running # yum clean all command should smartly check the disk space consumed by the disabled repositories and  show warning message only if there is significant amount of space consumed by the disabled repositories.


7. Is there already an existing RFE upstream or in Red Hat Bugzilla?

- No

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?

- Issue needs to be resolved as soon as possible

9. Is the sales team involved in this request and do they have any additional input?

- No


10. List any affected packages or components.

- yum-3.4.3-154.el7.noarch


11. Would the customer be able to assist in testing this functionality if implemented?

- Yes

Comment 18 errata-xmlrpc 2018-10-30 11:40:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3279