Bug 1481846

Summary: appliance_console_cli doesn't handle ipa registration if the password has a '$' in it
Product: Red Hat CloudForms Management Engine Reporter: Satoe Imaishi <simaishi>
Component: ApplianceAssignee: Yuri Rudman <yrudman>
Status: CLOSED ERRATA QA Contact: Matt Pusateri <mpusater>
Severity: low Docs Contact:
Priority: medium    
Version: 5.7.0CC: abellott, jhardy, obarenbo, simaishi, yrudman
Target Milestone: GAKeywords: ZStream
Target Release: 5.8.2   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: appliance:auth
Fixed In Version: 5.8.2.0 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1438974 Environment:
Last Closed: 2017-10-24 00:39:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core Target Upstream Version:
Bug Depends On: 1438974    
Bug Blocks:    

Comment 2 CFME Bot 2017-08-15 21:13:15 UTC
New commit detected on ManageIQ/manageiq-gems-pending/fine:
https://github.com/ManageIQ/manageiq-gems-pending/commit/5be8085f865e889b33b2f6871318dcf97b0f9305

commit 5be8085f865e889b33b2f6871318dcf97b0f9305
Author:     Brandon Dunne <brandondunne@hotmail.com>
AuthorDate: Tue Aug 15 11:57:23 2017 -0400
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Tue Aug 15 17:09:30 2017 -0400

    Merge pull request #257 from yrudman/allow-httpd-password-to-have-dollar-sign
    
    Allow httpd password to have dollar sign in it
    (cherry picked from commit 7bea4f3d0ebda0ef479110b7c61e42e9dbf72834)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1481846

 .../external_httpd_authentication.rb               |  2 +-
 .../external_httpd_authentication_spec.rb          | 22 ++++++++++++++++++++++
 2 files changed, 23 insertions(+), 1 deletion(-)

Comment 6 Matt Pusateri 2017-10-04 21:42:13 UTC
Verified on 5.8.2.1

Comment 8 errata-xmlrpc 2017-10-24 00:39:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2017:3005