Bug 1482953

Summary: tunir: Switch to Python 3 / nonresponsive maintainer
Product: [Fedora] Fedora Reporter: Iryna Shcherbina <ishcherb>
Component: tunirAssignee: kushaldas <mail>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: mail, mhroncok
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-06-17 11:29:26 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1285816    

Description Iryna Shcherbina 2017-08-18 13:21:05 UTC
Upstream, this software supports Python 3 [0]. Please provide a Python 3
package for Fedora.


According to the Python packaging guidelines [1], software must be
packaged for Python 3 if upstream supports it.
The guidelines give detailed information on how to do this, and even
provide an example spec file [2].

Since users aren't expected to import this tool from Python code,
you can just switch to /usr/bin/python3. Alternatively, if you want or
need to keep a Python 2 version, the current best practice is to provide
subpackages -- this is called "Common SRPM" in the guidelines.

It's OK to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 26 as well.


If you need more instructions, a guide for porting Python-based RPMs is
available at [3].
If anything is unclear, or if you need any kind of assistance with the
porting, you can ask on IRC (#fedora-python on Freenode), or reply here.
We'll be happy to help!


[0] http://tunir.readthedocs.io/en/latest/installation.html#installation
[1] https://fedoraproject.org/wiki/Packaging:Python
[2] https://fedoraproject.org/wiki/Packaging:Python#Example_common_spec_file
[3] http://python-rpm-porting.readthedocs.io/

Comment 1 Fedora End Of Life 2018-02-20 15:32:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 28 development cycle.
Changing version to '28'.

Comment 2 Miro Hrončok 2019-03-17 21:51:11 UTC
Kushal, are you still with us?

Comment 3 kushaldas@gmail.com 2019-03-18 02:40:31 UTC
>Kushal, are you still with us?

I am, but, too many things on plate. IIRC, I updated Tunir codebase with Python3, but, have to work on the packaging side. I will try to
put one day this week to clear all different packaging tasks hanging on me.

Comment 4 Miro Hrončok 2019-03-18 06:31:39 UTC
Thanks! If you want me to the the packaging part, let me know.

Comment 5 Miro Hrončok 2019-04-03 12:52:29 UTC
I'm bumping the fact that I am able to help, just let me know.

Comment 6 Ben Cotton 2019-05-02 19:43:39 UTC
This message is a reminder that Fedora 28 is nearing its end of life.
On 2019-May-28 Fedora will stop maintaining and issuing updates for
Fedora 28. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora 'version' of '28'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 28 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 7 Miro Hrončok 2019-05-27 08:51:21 UTC
I'm sorry, but I was unable to reach Kushal ever again via e-mail or here.

Consider this now a https://docs.fedoraproject.org/en-US/fesco/Policy_for_nonresponsive_package_maintainers/ BZ tracker at point 2.

Kushal, please orphan the package or respond.

Comment 8 Miro Hrončok 2019-06-03 10:12:20 UTC
Kushal, please orphan the package or respond.

Comment 9 Miro Hrončok 2019-06-10 12:28:10 UTC
I've reached Kushal on IRC a week ago, he said he'll orphan tunir but it didn't happen :(

Comment 10 Miro Hrončok 2019-06-17 11:13:31 UTC
Still no response or action taken.

Comment 11 Miro Hrončok 2019-06-17 11:28:11 UTC
https://pagure.io/fesco/issue/2148

Comment 12 Miro Hrončok 2019-06-17 11:29:26 UTC
Package was retired. Sorry, I was looking at the owner and forgot to check such fundamental thing.