Bug 1483701

Summary: [RFE] Cinder iSCSI multipath robustness
Product: Red Hat OpenStack Reporter: Sean Cohen <scohen>
Component: openstack-cinderAssignee: Gorka Eguileor <geguileo>
Status: CLOSED ERRATA QA Contact: Avi Avraham <aavraham>
Severity: high Docs Contact: Don Domingo <ddomingo>
Priority: high    
Version: 13.0 (Queens)CC: cschwede, geguileo, knylande, srevivo, tshefi
Target Milestone: Upstream M1Keywords: FutureFeature, TestOnly, Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-cinder-12.0.0-0.20180104034246.26e8be8.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:34:14 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sean Cohen 2017-08-21 18:56:10 UTC
Over the last 5 releases we have 14 different iSCSI multipath bugs (1443612, 1445192,1441066,1443178, 1428662, 1442637, 1406617, 1428962, 1440576, 1396112, 	1418856, 1426441, 1426442, 1386469)			

However, in order to validate the robustness of the iSCSI multipath code in
OpenStack we require harsher tests than those we have, since they only
test the "happy code path".

This RFE is aimed to cover error injecting tests with validation to confirm there
are no leftovers after an attach or detach failure and an appropriate
explanation in our documentation.

Comment 7 Avi Avraham 2018-04-03 12:44:51 UTC
Verified in RPM package:
openstack-cinder-12.0.1-0.20180326201852.46c4ec1.el7ost.noarch
According to Polarion test run: 
20180220-1116 - [cinder] iSCSI multipath robustness

Comment 10 errata-xmlrpc 2018-06-27 13:34:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086