Bug 1484955

Summary: Assertion assert "m_widget" failed in Show(): invalid frame
Product: [Fedora] Fedora Reporter: Vitaly Zaitsev <vitaly>
Component: wxGTK3Assignee: Scott Talbert <swt>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 26CC: alexjnewt, bruno.lewillon, c72578, gwync, iouddocco, kwizart, swt
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: wxGTK3-3.0.3-5.fc26 wxGTK3-3.0.3-5.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-09-05 00:51:03 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Vitaly Zaitsev 2017-08-24 16:03:47 UTC
Description of problem:
Annoying error message on every FileZilla launch:
./src/gtk/toplevel.cpp(988): assert "m_widget" failed in Show(): invalid frame


Version-Release number of selected component (if applicable):
filezilla = 3.27.1-1.fc26 (x86_64)
libfilezilla = 0.10.1-1.fc26 (x86_64)


How reproducible:
Always.


Steps to Reproduce:
1. (optional) Remove all FileZilla settings: rm -rf ~/.config/filezilla
2. Run FileZilla, then close it.
3. Run FileZilla again. Assertion failed dialog will appear.

Actual results:
ASSERT INFO:
./src/gtk/toplevel.cpp(988): assert "m_widget" failed in Show(): invalid frame

BACKTRACE:
[1] wxTopLevelWindowGTK::Show(bool)
[2] wxTopLevelWindowBase::Destroy()
[3] wxEvtHandler::ProcessEventIfMatchesId(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&)
[4] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*)
[5] wxEvtHandler::TryHereOnly(wxEvent&)
[6] wxEvtHandler::ProcessEventLocally(wxEvent&)
[7] wxEvtHandler::ProcessEvent(wxEvent&)
[8] wxEvtHandler::SafelyProcessEvent(wxEvent&)
[9] wxTimerImpl::SendEvent()
[10] g_main_context_dispatch
[11] g_main_loop_run
[12] gtk_main
[13] wxGUIEventLoop::DoRun()
[14] wxEventLoopBase::Run()
[15] wxAppConsoleBase::MainLoop()
[16] wxEntry(int&, wchar_t**)
[17] __libc_start_main


Expected results:
No error messages should be shown.

Additional info:
Fedora 26 with KDE Plasma 5.

Comment 1 iouddocco 2017-08-26 14:41:52 UTC
FileZilla developer says it's due to a bug in wxWidgets (package: wxGTK3), and has posted a patch:
https://forum.filezilla-project.org/viewtopic.php?p=157690&sid=a2f204e02f6c58970616a5fe5c3f2a3c#p157690

Comment 2 Scott Talbert 2017-08-28 02:11:32 UTC
@iouddocco, can you please as Tim to open a pull request with wxWidgets upstream with his patch?  I would like to get upstream review on it.

Comment 3 iouddocco 2017-08-28 16:32:19 UTC
wxWidgets upstream pull request:
https://trac.wxwidgets.org/ticket/17942

Comment 4 Fedora Update System 2017-09-01 11:55:33 UTC
wxGTK3-3.0.3-5.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a6f10feeda

Comment 5 Fedora Update System 2017-09-03 19:52:23 UTC
wxGTK3-3.0.3-5.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-dc4180a337

Comment 6 Bruno Lewillon 2017-09-03 22:02:42 UTC
I'm sorry if it was not at this place that I had to leave a comment, this is the first time I use this feature.
I have identically the same problem under Manjaro 17.02 XFCE:

Filezilla 3.27.1

./src/gtk/toplevel.cpp(988): assert "m_widget" failed in Show(): invalid frame

ASSERT INFO:
./src/gtk/toplevel.cpp(988): assert "m_widget" failed in Show(): invalid frame

BACKTRACE:
[1] wxTopLevelWindowGTK::Show(bool)
[2] wxTopLevelWindowBase::Destroy()
[3] wxEvtHandler::ProcessEventIfMatchesId(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&)
[4] wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*)
[5] wxEvtHandler::TryHereOnly(wxEvent&)
[6] wxEvtHandler::ProcessEventLocally(wxEvent&)
[7] wxEvtHandler::ProcessEvent(wxEvent&)
[8] wxEvtHandler::SafelyProcessEvent(wxEvent&)
[9] wxTimerImpl::SendEvent()
[10] g_main_context_dispatch
[11] g_main_loop_run
[12] gtk_main
[13] wxGUIEventLoop::DoRun()
[14] wxEventLoopBase::Run()
[15] wxAppConsoleBase::MainLoop()
[16] wxEntry(int&, wchar_t**)
[17] __libc_start_main

Comment 7 Scott Talbert 2017-09-04 00:36:59 UTC
@Bruno, unfortunately, you'll have to report the problem to Manjaro separately.  This bug report only addresses the issue in Fedora.

Comment 8 Fedora Update System 2017-09-05 00:51:03 UTC
wxGTK3-3.0.3-5.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2017-09-30 06:06:21 UTC
wxGTK3-3.0.3-5.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.