Bug 1485014

Summary: cluster name hard coded to 'ceph' in /usr/lib/phython2.7/site-packages/ceph_disk/main.py
Product: Red Hat Ceph Storage Reporter: Justin Bautista <jbautist>
Component: Ceph-DiskAssignee: Kefu Chai <kchai>
Status: CLOSED WONTFIX QA Contact: ceph-qe-bugs <ceph-qe-bugs>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.3CC: bhubbard, jdurgin, mhackett
Target Milestone: rc   
Target Release: 2.*   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-01-18 22:30:29 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Justin Bautista 2017-08-24 20:34:35 UTC
Description of problem:

Customer has reported that the mount options from cluster config are not applying because they have cluster with name 'ceph-sv4' 

While the OSDs are mounting, ceph-disk seems to be using hardcoded cluster name 'ceph' in /usr/lib/python2.7/site-packages/ceph_disk/main.py

    # TODO always using mount options from cluster=ceph for
    # now; see http://tracker.newdream.net/issues/3253
    mount_options = get_mount_options(cluster='ceph', fs_type=fstype)
===========================================================================

Instead of 'ceph' should this be '$cluster-$id' (or something equivalent)?

In the meantime, is there a workaround, other than fstab, to use mount options for ceph config when cluster name isn't default?

Comment 2 Josh Durgin 2019-01-18 22:30:29 UTC
This isn't severe enough to change ceph-disk for at this point.