Bug 1485804

Summary: [downstream clone - 4.1.6] Unable to Import a VM linked with its template to RHV 4.1 from export domain imported of RHEV 3.5
Product: Red Hat Enterprise Virtualization Manager Reporter: rhev-integ
Component: ovirt-engineAssignee: Tomas Jelinek <tjelinek>
Status: CLOSED ERRATA QA Contact: Nisim Simsolo <nsimsolo>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.1.2CC: kshukla, lsurette, lveyde, mavital, melewis, michal.skrivanek, nsimsolo, rbalakri, Rhev-m-bugs, srevivo, tjelinek, tnisan, ykaul, ylavi
Target Milestone: ovirt-4.1.6Keywords: ZStream
Target Release: ---Flags: lsvaty: testing_plan_complete-
Hardware: Unspecified   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Previously, when a template was the base template it was always enforced that it must be imported as a clone. This meant that if a virtual machine that was based on the base template was imported then the virtual machine would also be imported as a clone. Now, the way clone enforcing is detected has been corrected so that base templates are not artificially enforced to be imported as clones.
Story Points: ---
Clone Of: 1484392 Environment:
Last Closed: 2017-09-19 07:18:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Virt RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1484392    
Bug Blocks:    

Description rhev-integ 2017-08-28 06:43:51 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1484392 +++
======================================================================

Description of problem:

Unable to Import a VM linked with its template to RHV 4.1 from export domain imported of RHEV 3.5

We see below things when Importing a Template in RHV 4.1 from export domain imported from RHEV 3.5 environment. 

1. Click Import template from export domain. We see check mark in option 
"clone" already greyed out. Unable to remove this check mark.

2. Upon proceeding we get "Import conflict" dailog box asking to either "clone" change the name of the template OR "Do not Import".  This screen is seen even when we have no template with same name existing in RHV 4.1 environment.

3. We can import the template sucessfully by changing the name of the template in  "Import conflict" dailog box.

4. When we try to import the VM linked with the template. We see check mark in "collapse snapshot" option is greyed out. Unable to remove this check mark.

5. We also get below message. Not sure if this is a error or just a general message.

"Some imported VMs depend on one or more templates which are not available in the system. Therefore you must Import those VMs with 'collapse snapshots', another option is to Import missing templates first and then try import the VMs again"

6. VM can be imported but it is unlinked with the template because of "collapse snapshot" option.

We are unable to import the vm linked with the template from the export domain (imported from 3.5) to RHV 4.1 environment.

Version-Release number of selected component (if applicable):
rhevm-4.1.2.3-0.1.el7.noarch

How reproducible: 100%

Steps to Reproduce:
1. Export a template & its linked VM in RHEV 3.5 environment to export domain.
2. Detach export domain and attach it to RHV 4.1 environment.
3. Try to Import the template and then its VM.

Actual results:

We are unable to import the vm linked with the template from the export domain (imported from 3.5) to RHV 4.1 environment.
Template is imported with name change. VM is imported without the link to template.

Expected results:

We should not get the "Import conflict" dailog box when trying to import the template which is new and no template with same name already exists. Also the vm should be imported without removing the link with the template.

Additional info:

(Originally by Koutuk Shukla)

Comment 8 Nisim Simsolo 2017-09-13 13:07:02 UTC
Verification builds:
ovirt-engine-4.1.6.2-0.1.el7
vdsm-4.19.31-1.el7ev.x86_64
qemu-kvm-rhev-2.9.0-16.el7_4.5.x86_64
libvirt-client-3.2.0-14.el7_4.3.x86_64
sanlock-3.5.0-1.el7.x86_64

Verification scenario:
1. Export a template & its linked VM in RHEV 3.5 environment to export domain.
2. Detach export domain and attach it to RHV 4.1 environment.
3. Try to Import the template and then its VM.

Results:
1. Import template - clone is not checked by default and can be checked/unchecked.
2. Import dialog is not enforcing to change imported template name.
3. Template imported successfully.
4. Importing VM linked with aforementioned template: collapse snapshot is checked by default and clone is unchecked by default. 
Collapse snapshot checkbox is not grayed out and can be unchecked.
5. no message related to "vm depends on template" observed.
6. VM imported succesfully, linked with it's template and VM is running properly.

Comment 10 errata-xmlrpc 2017-09-19 07:18:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:2749

Comment 11 Daniel Gur 2019-08-28 12:57:56 UTC
sync2jira

Comment 12 Daniel Gur 2019-08-28 13:03:04 UTC
sync2jira

Comment 13 Daniel Gur 2019-08-28 13:14:16 UTC
sync2jira

Comment 14 Daniel Gur 2019-08-28 13:19:17 UTC
sync2jira