Bug 1487078

Summary: EnableLldpError: (255, '', 'connect: Connection refused\nFailed to connect to lldpad - clif_open: Invalid argument\n', 'enp12s0f1')
Product: [oVirt] vdsm Reporter: Michael Burman <mburman>
Component: SuperVDSMAssignee: Dominik Holler <dholler>
Status: CLOSED CURRENTRELEASE QA Contact: Michael Burman <mburman>
Severity: medium Docs Contact:
Priority: high    
Version: 4.20.0CC: bugs, danken, dholler, lveyde
Target Milestone: ovirt-4.1.6Flags: rule-engine: ovirt-4.1+
Target Release: 4.19.31   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: vdsm v4.19.31 Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-09-19 10:03:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Network RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Attachments:
Description Flags
supervdsm log none

Description Michael Burman 2017-08-31 08:30:37 UTC
Created attachment 1320507 [details]
supervdsm log

Description of problem:
EnableLldpError: (255, '', 'connect: Connection refused\nFailed to connect to lldpad - clif_open: Invalid argument\n', 'enp12s0f1')

supervdsm.log is spammed with EnableLlldpError on all ports after updating to selinux-policy-targeted-3.13.1-166.el7_4.4.noarch

Version-Release number of selected component (if applicable):
vdsm-4.20.2-132.git936e6cc.el7.centos.x86_64
selinux-policy-targeted-3.13.1-166.el7_4.4.noarch
lldpad-1.0.1-3.git036e314.el7.x86_64

How reproducible:
100

Steps to Reproduce:
1. Update host with vdsm 4.2 with selinux-policy-targeted-3.13.1-166.el7_4.4.noarch
2. Check for supervdsm logs

Actual results:
lldp errros in supervdsm log

Expected results:
Should be no erros

Comment 1 Michael Burman 2017-08-31 08:36:55 UTC
MainThread::ERROR::2017-08-30 22:26:12,040::initializer::53::root::(_lldp_init) Failed to enable LLDP on eno1
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/vdsm/network/initializer.py", line 51, in _lldp_init
    Lldp.enable_lldp_on_iface(device)
  File "/usr/lib/python2.7/site-packages/vdsm/network/lldp/lldpad.py", line 30, in enable_lldp_on_iface
    lldptool.enable_lldp_on_iface(iface, rx_only)
  File "/usr/lib/python2.7/site-packages/vdsm/network/lldpad/lldptool.py", line 46, in enable_lldp_on_iface
    raise EnableLldpError(rc, out, err, iface)
EnableLldpError: (255, '', 'connect: Connection refused\nFailed to connect to lldpad - clif_open: Invalid argument\n', 'eno1')

Comment 2 Dominik Holler 2017-08-31 10:33:37 UTC
Looks like supervdsmd is initialized before lldpad is up:

[root@navy-vds1 ~]# journalctl -xu lldpad
-- Logs begin at Thu 2017-08-31 16:09:37 IDT, end at Thu 2017-08-31 13:21:35 IDT. --
Aug 31 13:10:49 navy-vds1.qa.lab.tlv.redhat.com systemd[1]: Started Link Layer Discovery Protocol Agent Daemon..
-- Subject: Unit lldpad.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit lldpad.service has finished starting up.
-- 
-- The start-up result is done.
Aug 31 13:10:49 navy-vds1.qa.lab.tlv.redhat.com systemd[1]: Starting Link Layer Discovery Protocol Agent Daemon....
-- Subject: Unit lldpad.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit lldpad.service has begun starting up.
[root@navy-vds1 ~]# journalctl -xu supervdsmd
-- Logs begin at Thu 2017-08-31 16:09:37 IDT, end at Thu 2017-08-31 13:22:35 IDT. --
Aug 31 13:10:00 navy-vds1.qa.lab.tlv.redhat.com systemd[1]: Started Auxiliary vdsm service for running helper functions as root.
-- Subject: Unit supervdsmd.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit supervdsmd.service has finished starting up.
-- 
-- The start-up result is done.
Aug 31 13:10:00 navy-vds1.qa.lab.tlv.redhat.com systemd[1]: Starting Auxiliary vdsm service for running helper functions as root...
-- Subject: Unit supervdsmd.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit supervdsmd.service has begun starting up.

Comment 3 Red Hat Bugzilla Rules Engine 2017-08-31 12:09:10 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 4 rhev-integ 2017-08-31 16:51:38 UTC
INFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Tag 'v4.19.30' doesn't contain patch 'https://gerrit.ovirt.org/81264']
gitweb: https://gerrit.ovirt.org/gitweb?p=vdsm.git;a=shortlog;h=refs/tags/v4.19.30

For more info please contact: infra

Comment 5 Michael Burman 2017-09-06 05:58:29 UTC
Dominik this bug is targeted to 4.1.6 and can't be ON_QA, as we don't have any new build.

Comment 6 Michael Burman 2017-09-10 10:42:54 UTC
Verified on - vdsm-4.19.31-1.el7ev.x86_64