Bug 1487980

Summary: Install OCP by ansible-2.2.3.0-1.el7 met syntax problem
Product: OpenShift Container Platform Reporter: Wenkai Shi <weshi>
Component: InstallerAssignee: Scott Dodson <sdodson>
Status: CLOSED ERRATA QA Contact: Wenkai Shi <weshi>
Severity: high Docs Contact:
Priority: high    
Version: 3.7.0CC: aos-bugs, jokerman, mmccomas, wmeng
Target Milestone: ---   
Target Release: 3.7.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openshift-ansible-3.7.0-0.126.1.git.0.0bb5b0c.el7.noarch Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-28 22:09:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Wenkai Shi 2017-09-04 03:18:37 UTC
Description of problem:
Install OCP by ansible-2.2.3.0-1.el7 met syntax problem, update to ansible-2.3.2.0-1.el7 syntax problem disappear.
The ansible-2.2.3.0-1.el7 is from OCP repo, the ansible-2.3.2.0-1.el7 is from RHEL extras repo.

Version-Release number of the following components:
ansible-2.2.3.0-1.el7
atomic-openshift-utils-3.7.0-0.123.0.git.0.248cba6.el7

How reproducible:
100%

Steps to Reproduce:
1. Install OCP by ansible-2.2.3.0-1.el7
2.
3.

Actual results:
# ansible-playbook -i hosts -v /usr/share/ansible/openshift-ansible/playbooks/byo/config.yml 
Using /etc/ansible/ansible.cfg as config file
ERROR! 'name' is not a valid attribute for a Block

The error appears to have been in '/usr/share/ansible/openshift-ansible/roles/openshift_node/tasks/tuned.yml': line 10, column 3, but may
be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:


- name: Tuned service setup
  ^ here


Expected results:
Installation succeed.

Additional info:

Comment 1 Scott Dodson 2017-09-06 16:53:24 UTC
The installer now requires ansible-2.3 which is available in RHEL extras.

Comment 2 Scott Dodson 2017-09-06 16:54:36 UTC
Clarification, the master branch requires ansible 2.3, older releases should continue to work with 2.2.x for the time being.

Comment 3 Wenkai Shi 2017-09-11 03:23:50 UTC
So far the latest puddle is 3.7.0-0.125.0.git.0.91043b6, no 3.7.0-0.125.1.git.0.99e6845 found. 
# yum install atomic-openshift-utils -y
...
Processing Dependency: ansible >= 2.2.2.0 for package: openshift-ansible-3.7.0-0.125.0.git.0.91043b6.el7.noarch
...

By the way, are we going to required ansible 2.3 by rpm dependency or document? Is there any PR?

Comment 5 Wenkai Shi 2017-09-14 08:27:18 UTC
Verified with version openshift-ansible-3.7.0-0.126.1.git.0.0bb5b0c.el7. 

# yum install atomic-openshift-utils -y
...
--> Processing Dependency: ansible >= 2.3 for package: openshift-ansible-3.7.0-0.126.1.git.0.0bb5b0c.el7.noarch
...

# rpm -q ansible
ansible-2.3.2.0-2.el7.noarch

Comment 9 errata-xmlrpc 2017-11-28 22:09:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2017:3188