Bug 1490447

Summary: [RFE] option to collect logs from one host per cluster
Product: Red Hat Enterprise Virtualization Manager Reporter: Dan Kenigsberg <danken>
Component: ovirt-log-collectorAssignee: Ala Hino <ahino>
Status: CLOSED ERRATA QA Contact: Lukas Svaty <lsvaty>
Severity: medium Docs Contact:
Priority: high    
Version: 2.1.0CC: bugs, danken, lsvaty, mkalinin, trichard, ylavi
Target Milestone: ovirt-4.2.0Keywords: FutureFeature
Target Release: ---Flags: lsvaty: testing_plan_complete-
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: ovirt-log-collector-4.2.0-1.el7ev Doc Type: Enhancement
Doc Text:
Previously, data was collected from all hosts in a cluster, which created an output file that was too large to handle. In this release, the hypervisor-per-cluster option enables you to collect data from a single host (the Storage Pool Manager, if available) per cluster.
Story Points: ---
Clone Of:
: 1512307 1512308 (view as bug list) Environment:
Last Closed: 2018-05-15 17:31:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Integration RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1509653, 1512307, 1512308    

Description Dan Kenigsberg 2017-09-11 14:57:01 UTC
Description of problem:
ovirt-log-collector collects logs from all hosts, which makes its output too big to handle. Specifying a list of hypervisors by name is tedious and error-prone. People tend to be using --no-hypervisor and miss the purpose.

This RFE is about adding a midway --one-hypervisor-per-cluster. When supplied to the script, the script would choose one host per cluster, and collect its logs. The current SPM and the current host of a self-hosted-engine should be included as well.

Comment 1 Dan Kenigsberg 2017-11-07 13:36:28 UTC
We would like to backport this to 3.6-els, to ease log collection prior to upgrade.

Comment 3 Lukas Svaty 2017-11-08 11:49:20 UTC
My 2 cents:
1. If this will be turned off by default, customers won't be using it / will keep using --no-hypervisor
2. "--one-hypervisor-per-cluster" name is too long, I would prefer something shorter and more user-friendly such as 
3. Easy way to fix 1. would be to ask question on --no-hypervisor to include at least 1 or if user is sure that hypervisors should be omitted

QS:
What host do we choose? SPM? With PM? First host? Random host? Does it matter for DEV on debugging side?

Comment 6 Dan Kenigsberg 2017-11-12 15:20:55 UTC
I think I misused the clone job, but managed to cloned to everything but 4.0 (no such target milestone)

Comment 8 Lukas Svaty 2018-01-26 15:03:53 UTC
verified in ovirt-log-collector-4.2.0-1.el7ev.noarch

Comment 13 errata-xmlrpc 2018-05-15 17:31:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1465

Comment 14 Franta Kust 2019-05-16 13:06:57 UTC
BZ<2>Jira Resync