Bug 1490700
| Summary: | cns-deploy failed: error while deploying deploy-heketi-pod | ||||||
|---|---|---|---|---|---|---|---|
| Product: | [Red Hat Storage] Red Hat Gluster Storage | Reporter: | Apeksha <akhakhar> | ||||
| Component: | cns-deploy-tool | Assignee: | Michael Adam <madam> | ||||
| Status: | CLOSED ERRATA | QA Contact: | Apeksha <akhakhar> | ||||
| Severity: | urgent | Docs Contact: | |||||
| Priority: | unspecified | ||||||
| Version: | cns-3.6 | CC: | hchiramm, jarrpa, kramdoss, pprakash, rcyriac, rhs-bugs, vinug | ||||
| Target Milestone: | --- | Keywords: | Regression | ||||
| Target Release: | CNS 3.6 | ||||||
| Hardware: | x86_64 | ||||||
| OS: | Linux | ||||||
| Whiteboard: | |||||||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |||||
| Doc Text: | Story Points: | --- | |||||
| Clone Of: | Environment: | ||||||
| Last Closed: | 2017-10-11 07:14:24 UTC | Type: | Bug | ||||
| Regression: | --- | Mount Type: | --- | ||||
| Documentation: | --- | CRM: | |||||
| Verified Versions: | Category: | --- | |||||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||
| Embargoed: | |||||||
| Bug Depends On: | |||||||
| Bug Blocks: | 1445448 | ||||||
| Attachments: |
|
||||||
Attached the complete cns-deploy.log file cns-deploy v37 has the fix. CI has passed on build - cns-deploy-5.0.0-37.el7rhgs.x86_64, cns-deploy passed successfully [root@dhcp47-54 ~]# oc get pods NAME READY STATUS RESTARTS AGE glusterblock-provisioner-dc-1-297h2 1/1 Running 0 18h glusterfs-0t12l 1/1 Running 0 18h glusterfs-pbfq1 1/1 Running 0 18h glusterfs-wsh38 1/1 Running 0 18h heketi-1-jwn3r 1/1 Running 0 18h nginx1 1/1 Running 0 18h nginx2 1/1 Running 0 18h storage-project-router-1-mwglw 1/1 Running 0 18h Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory, and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHEA-2017:2881 |
Created attachment 1324662 [details] cns_deploy.log Description of problem: cns-deploy failed: error while deploying deploy-heketi-pod Version-Release number of selected component (if applicable): cns-deploy-5.0.0-35.el7rhgs.x86_64 heketi-client-5.0.0-11.el7rhgs.x86_64 openshift v3.6.173.0.21 kubernetes v1.6.1+5115d708d7 How reproducible: CI failed- once on this build Steps to Reproduce: 1. Setup OCP and router 2. Run cns-deploy, it fails [root@dhcp47-54 ~]# oc get pods NAME READY STATUS RESTARTS AGE deploy-heketi-1-deploy 0/1 Error 0 5h glusterfs-24t91 1/1 Running 0 5h glusterfs-90ltd 1/1 Running 0 5h glusterfs-b6hls 1/1 Running 0 5h storage-project-router-1-jv6j5 1/1 Running 0 5h output -f cn-deploy command: deploy-heketi-1-np6pt 0/1 CrashLoopBackOff 3 3m --- deploy-heketi-1-np6pt 0/1 CrashLoopBackOff 3 3m --- deploy-heketi-1-np6pt 0/1 Running 4 3m --- deploy-heketi-1-np6pt 0/1 Error 4 3m --- deploy-heketi-1-np6pt 0/1 Error 4 3m --- deploy-heketi-1-np6pt 0/1 Error 4 3m --- deploy-heketi-1-np6pt 0/1 CrashLoopBackOff 4 3m --- deploy-heketi-1-np6pt 0/1 CrashLoopBackOff 4 3m --- deploy-heketi-1-np6pt 0/1 CrashLoopBackOff 4 3m --- --- No resources found. --- No resources found. --- No resources found. --- No resources found. --- No resources found. Timed out waiting for pods matching '--selector=deploy-heketi=pod'. pod not found.