Bug 1490817

Summary: objectweb-asm: org.objectweb.asm.tree,6.0.0.BETA is not a valid bundle
Product: [Fedora] Fedora Reporter: Mikolaj Izdebski <mizdebsk>
Component: objectweb-asmAssignee: Mikolaj Izdebski <mizdebsk>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: dwalluck, fnasser, java-sig-commits, mizdebsk, msimacek
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: 6.0-0.2.beta Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-09-12 10:36:02 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mikolaj Izdebski 2017-09-12 10:03:19 UTC
osgi.bundle,org.objectweb.asm.commons,6.0.0.BETA (/var/lib/mock/maven/root/usr/share/java/objectweb-asm/asm-commons.jar) is not a valid bundle so it will be ignored.
osgi.bundle,org.objectweb.asm.analysis,6.0.0.BETA (/var/lib/mock/maven/root/usr/share/java/objectweb-asm/asm-analysis.jar) is not a valid bundle so it will be ignored.
osgi.bundle,org.objectweb.asm.tree,6.0.0.BETA (/var/lib/mock/maven/root/usr/share/java/objectweb-asm/asm-tree.jar) is not a valid bundle so it will be ignored.
osgi.bundle,org.objectweb.asm.util,6.0.0.BETA (/var/lib/mock/maven/root/usr/share/java/objectweb-asm/asm-util.jar) is not a valid bundle so it will be ignored.


Caused by: java.lang.IllegalArgumentException: invalid version "6.0_BETA": non-numeric "0_BETA"
	at org.osgi.framework.Version.parseInt(Version.java:170)
	at org.osgi.framework.Version.<init>(Version.java:130)
	at org.osgi.framework.Version.valueOf(Version.java:257)
	at org.osgi.framework.VersionRange.parseVersion(VersionRange.java:194)
	... 61 more
Caused by: java.lang.NumberFormatException: For input string: "0_BETA"
	at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
	at java.lang.Integer.parseInt(Integer.java:580)
	at java.lang.Integer.parseInt(Integer.java:615)
	at org.osgi.framework.Version.parseInt(Version.java:168)
	... 64 more

Comment 1 Mikolaj Izdebski 2017-09-12 10:23:23 UTC
Fixed in objectweb-asm-6.0-0.2.beta

Comment 2 Mikolaj Izdebski 2017-09-12 10:36:02 UTC
I believe that this bug is fixed in objectweb-asm-6.0-0.2.beta,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=969394