Bug 1491412

Summary: [3.6] Installer does not configure flannel correctly for openstack installs.
Product: OpenShift Container Platform Reporter: Scott Dodson <sdodson>
Component: InstallerAssignee: Scott Dodson <sdodson>
Status: CLOSED ERRATA QA Contact: Gan Huang <ghuang>
Severity: high Docs Contact:
Priority: high    
Version: 3.6.0CC: aos-bugs, eminguez, erich, jchaloup, jialiu, jokerman, misalunk, mmccomas, myllynen, rhowe, sdodson
Target Milestone: ---   
Target Release: 3.6.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
The flannel network was previously defined using the same subnet as the kubernetes services subnet. This caused a conflict between services and SDN networks. The flannel network is now correctly defined by the osm_cluster_network_cidr variable.
Story Points: ---
Clone Of: 1473858 Environment:
Last Closed: 2017-10-17 11:45:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1473858, 1491413, 1594310    
Bug Blocks:    

Comment 4 Gan Huang 2017-10-12 10:10:22 UTC
DNS issue still persists in 3.6 (https://bugzilla.redhat.com/show_bug.cgi?id=1490820), but unrelated to this bug.

Verified in openshift-ansible-3.6.173.0.48-1.git.0.1609d30.el7.noarch.rpm

Comment 6 errata-xmlrpc 2017-10-17 11:45:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2900