Bug 1492601

Summary: DNF System Upgrade fails to upgrade to F27
Product: [Fedora] Fedora Reporter: Jiri Eischmann <jeischma>
Component: dnf-plugin-system-upgradeAssignee: Orphan Owner <extras-orphan>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 26CC: extras-orphan, wwoods, zbyszek
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-09-18 09:45:57 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jiri Eischmann 2017-09-18 09:39:16 UTC
DNF System Upgrade fails to upgrade to Fedora 27. The logs say this:

zář 18 11:25:45 xps13-jeischma systemd[1]: Rebooting: service failed
zář 18 11:25:45 xps13-jeischma systemd[1]: dnf-system-upgrade.service: Failed with result 'exit-code'.
zář 18 11:25:45 xps13-jeischma systemd[1]: dnf-system-upgrade.service: Unit entered failed state.
zář 18 11:25:45 xps13-jeischma audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=dnf-system-upgrade comm="systemd" exe="/usr/lib/systemd/systemd" hostnam
zář 18 11:25:45 xps13-jeischma systemd[1]: Failed to start System Upgrade using DNF.
zář 18 11:25:45 xps13-jeischma systemd[1]: dnf-system-upgrade.service: Main process exited, code=exited, status=1/FAILURE
zář 18 11:25:45 xps13-jeischma dnf[966]: Chyba: žádný balíček není vhodný

The last line says: Error: no package is suitable.

I've been able to reproduce this on two different machines. I had to run 'dnf system-upgrade download --refresh --releasever=27' with updates-testing enabled to bypass the issue with grub2. Otherwise nothing special, my F26 machine is up-to-date.

Comment 1 Jiri Eischmann 2017-09-18 09:45:57 UTC
Looks like it's already reported. Closing as a duplicate.

*** This bug has been marked as a duplicate of bug 1490832 ***