Bug 149304

Summary: gaim MSN crash during chat idle timeout (?)
Product: [Fedora] Fedora Reporter: Warren Togami <wtogami>
Component: gaimAssignee: Warren Togami <wtogami>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: eblanton, lschiere+bugs, mark, stu, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-02-28 07:51:00 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 149273    

Description Warren Togami 2005-02-22 05:24:51 UTC
Description of problem:
gaim-1.1.3 crashed with the MSN protocol during an idle timeout, where you don't
chat in an MSN window for a while.  The crash would be between these two events
from "gaim -d" output.

(19:16:01) msn: S: SB 004: BYE somebody@hotmail.com 1
(19:16:01) msn: destroy httpconn (0x99ba5b0)

Unfortunately I have been unable to reproduce this while running gaim in gdb. 
Continuing to do so now to capture this crash info if it happens again.

Version-Release number of selected component (if applicable):
gaim-1.1.3-1.EL4

Comment 1 Warren Togami 2005-02-22 06:09:26 UTC
Still unable to reproduce using FC3 gaim-1.1.3, but it seems that RHEL3
gaim-1.1.3 reliably hangs instead of crashes here.  This seems to be a regression.


Comment 2 Stu Tomlinson 2005-02-23 01:55:31 UTC
This was caused by changes in Gaim 1.1.3 which were introduced to prevent
cancelling active file transfers with people you had active conversations with.
These crashes are fixed in upstream Gaim CVS and will be fixed in the upcoming
Gaim 1.1.4 release.

Comment 3 Warren Togami 2005-02-28 07:51:00 UTC
Resolved in gaim-1.1.4.