Bug 1495147

Summary: [Wayland][X11] Build failure with --enable-default-toolkit=cairo-gtk3
Product: [Fedora] Fedora Reporter: Hiroshi Hatake <cosmo0920.oucc>
Component: firefoxAssignee: Martin Stransky <stransky>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: alexl, ashie, gecko-bugs-nobody, jhorak, john.j5live, kengert, pjasicek, rhughes, rstrode, sandmann, stransky
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-09-25 11:14:05 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1054334    
Attachments:
Description Flags
Firefox Wayland Building failure log with --enable-default-toolkit=cairo-gtk3 none

Description Hiroshi Hatake 2017-09-25 09:59:05 UTC
Created attachment 1330470 [details]
Firefox Wayland Building failure log with --enable-default-toolkit=cairo-gtk3

Description of problem:

https://github.com/stransky/gecko-dev

How reproducible:

Always


Steps to Reproduce:
1. Specify --enable-default-toolkit=cairo-gtk3 instead of --enable-default-toolkit=cairo-gtk3-wayland into .mozconfig with https://github.com/stransky/gecko-dev
2. Run ./mach build

Actual results:

Build failure caused by undefined variables which are for Wayland patch


Expected results:

Building success even if --enable-default-toolkit=cairo-gtk3 is specified.


Additional info:

This is an obstacle for reporting Wayland patches into Bugzilla@Mozilla

Comment 1 Martin Stransky 2017-09-25 11:14:05 UTC
Added to commit 6f90fe49c2f311f3a9fdd0e610a55ff85752784c Thanks.

Comment 2 Hiroshi Hatake 2017-10-10 07:26:59 UTC
Thanks for your super fast fix.
But it seems that it is wrongly specified `--enable-default-toolkit=cairo-gtk3` in latest stransky/gecko-dev commit.
Is it intentional?

Comment 3 Martin Stransky 2017-10-10 09:26:43 UTC
(In reply to Hiroshi Hatake from comment #2)
> Thanks for your super fast fix.
> But it seems that it is wrongly specified
> `--enable-default-toolkit=cairo-gtk3` in latest stransky/gecko-dev commit.
> Is it intentional?

Ahh yes, that's a leftover after my testing. Will change that back, thanks.