Bug 1496148

Summary: Please remove weak dependency on python3-gssapi
Product: [Fedora] Fedora Reporter: Vojtech Trefny <vtrefny>
Component: python-paramikoAssignee: Othman Madjoudj <athmanem>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: athmanem, ignatenko, ivazqueznet, orion, paul, pcahyna, rebus, sgallagh
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-paramiko-2.3.1-2.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-09-30 06:56:10 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Vojtech Trefny 2017-09-26 14:40:21 UTC
Paramiko supports only "old" gssapi (<0.6)[1] but Fedora packages only the new API.

This is a big issue because since 2.2.2 paramiko fails to import because it expects the old API[2]. gssapi is not necessary to run paramiko and it runs just fine without it. They plan to fix this in 2.4.0[3] but right now 2.3.0 is unusable without removing "python3-gssapi" after installing "python3-paramiko".


[1] https://github.com/paramiko/paramiko/issues/584
[2] https://github.com/paramiko/paramiko/issues/1069
[3] https://github.com/paramiko/paramiko/pull/861

Comment 1 Othman Madjoudj 2017-09-26 20:34:28 UTC
Thank you for reporting, sorry I didn't catch it (I had install_weak_deps=False).
I'll push a fix in few

Comment 2 Fedora Update System 2017-09-26 21:58:11 UTC
python-paramiko-2.3.1-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e4d9a724c

Comment 3 Fedora Update System 2017-09-27 15:53:25 UTC
python-paramiko-2.3.1-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4e4d9a724c

Comment 4 Fedora Update System 2017-09-30 06:56:10 UTC
python-paramiko-2.3.1-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.