Bug 1497141

Summary: lorax: lorax requires both Python 2 and Python 3
Product: [Fedora] Fedora Reporter: Iryna Shcherbina <ishcherb>
Component: loraxAssignee: Brian Lane <bcl>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: anaconda-maint-list, bcl, dcantrell, dmach, mgracik, mhroncok, wwoods
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: lorax-28.0-1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-01-29 16:40:55 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1285816, 1312032, 1340802, 1396703    

Description Iryna Shcherbina 2017-09-29 09:54:07 UTC
The lorax RPM requires both Python 2 and Python 3.

Except in very special circumstances, there is no need for one package
to drag in both Python stacks. Usually, this is a packaging error: for
example, a stray "/usr/bin/python" shebang in a Python 3 package can
introduce a Python 2 dependency.

Please split your package, or remove the stray dependencies.
There is a section on shebangs in the Python RPM Porting Guide [0]
which covers this issue.

It's ok to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 27 as well.


If anything is unclear, or if you need any kind of assistance, you can
ask on IRC (#fedora-python on Freenode), or reply here. We'll be happy
to help investigating or fixing this issue!


[0] http://python-rpm-porting.readthedocs.io/en/latest/application-modules.html#are-shebangs-dragging-you-down-to-python-2

Comment 1 Iryna Shcherbina 2017-10-11 16:40:11 UTC
I have prepared a Pagure PR with the fix [0] for the issue and would kindly ask to review it and merge at will.

[0] https://src.fedoraproject.org/rpms/lorax/pull-request/1

Comment 2 Brian Lane 2017-10-11 17:32:26 UTC
Thanks, but running sed in the spec isn't the right way to fix this.

PR here - https://github.com/rhinstaller/lorax/pull/256

Comment 3 Iryna Shcherbina 2017-10-12 08:44:01 UTC
Hi Brian, fixing this upstream is even better. Thank you for taking a look and opening an upstream PR.

Comment 4 Fedora Blocker Bugs Application 2017-10-12 15:25:13 UTC
Proposed as a Freeze Exception for 27-beta by Fedora user bcl using the blocker tracking app because:

 Would be nice not to pull in python2

Comment 5 Brian Lane 2017-10-17 17:29:20 UTC
Fix pushed to rawhide only.