Bug 1498336

Summary: GDM fails to start when WaylandEnable=false due to selinux error
Product: [Fedora] Fedora Reporter: Benjamin Xiao <ben.r.xiao>
Component: selinux-policyAssignee: Lukas Vrabec <lvrabec>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 27CC: dwalsh, lsm5, lvrabec, mgrepl, plautrba, pmoore
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: selinux-policy-3.13.1-283.14.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-10-31 15:38:12 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
SELinux logs none

Description Benjamin Xiao 2017-10-04 04:33:14 UTC
Created attachment 1334035 [details]
SELinux logs

Description of problem:

GDM fails to start up due to a selinux error when WaylandEnable=false is set in /etc/gdm/custom.conf. I run the latest Nvidia driver and having Wayland enabled makes GDM really laggy. Upon disabling Wayland, GDM displays an error message and a Log Out button. I see selinux errors in journalctl.

Version-Release number of selected component (if applicable): selinux-policy 283.5.fc27


How reproducible:
Everytime


Steps to Reproduce:
1. Install Nvidia 384 drivers on Fedora 27
2. Uncomment WaylandEnable=false in /etc/gdm/custom.conf
3. Reboot

Actual results:
GDM fails to start with selinux error


Expected results:
GDM starts in Xorg


Additional info: selinux logs attached

Comment 1 Fedora Update System 2017-10-25 10:16:08 UTC
selinux-policy-3.13.1-283.13.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b5e9ce60d2

Comment 2 Fedora Update System 2017-10-27 18:47:20 UTC
selinux-policy-3.13.1-283.14.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b5e9ce60d2

Comment 3 Fedora Update System 2017-10-31 15:38:12 UTC
selinux-policy-3.13.1-283.14.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.