Bug 1498725

Summary: Massive screen corruption on KMS startup under kernel-PAE-4.13.4-200.fc26.i686 in Acer Aspire One
Product: [Fedora] Fedora Reporter: Alex Villacís Lasso <alexvillacislasso>
Component: kernelAssignee: Kernel Maintainer List <kernel-maint>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 27CC: airlied, ajax, andy, bskeggs, eparis, esandeen, hdegoede, ichavero, itamar, jarodwilson, jforbes, jglisse, jonathan, josef, jwboyer, kernel-maint, labbott, linville, malix0, mchehab, mjg59, nhorman, quintela, serhiy.int, steved
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-02-19 16:16:25 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1489998    
Attachments:
Description Flags
journalctl of affected kernel none

Description Alex Villacís Lasso 2017-10-05 04:53:14 UTC
Created attachment 1334604 [details]
journalctl of affected kernel

Description of problem:
After installing kernel update to 4.13.4 and rebooting, boot is normal until KMS takes over, then the display on the LCD gets garbled in a square area (800x800) at the left of the screen. The garbled area persists during the rest of the startup and into the login screen and makes the display unusable.

Previous kernel kernel-PAE-4.12.14-300.fc26.i686 does not garble the display, although it still shows a backtrace as described in #1438258, as this is the exact same machine.

Version-Release number of selected component (if applicable):
kernel-PAE-4.13.4-200.fc26.i686

How reproducible:
Always

Steps to Reproduce:
1. Acer Aspire One ZG5 32-bit with Fedora 26 and kernel-PAE-4.13.4-200.fc26.i686
2. Boot with updated kernel
3.

Actual results:
Garbled screen in a square section when KMS takes over.

Expected results:
No screen corruption.

Additional info:
Using journalctl I have captured a dmesg output of the affected kernel. Look for the string "plane B assertion failure, should be off on pipe B but is still active".

Comment 1 Alex Villacís Lasso 2017-10-11 02:07:58 UTC
Still present in kernel-PAE-4.13.5-200.fc26.i686

Comment 2 Alex Villacís Lasso 2017-10-11 15:24:14 UTC
Adding external bug at freedesktop.org .

Comment 3 Alex Villacís Lasso 2017-10-17 20:54:33 UTC
I was asked to test:

git://github.com/vsyrjala/linux.git plane_sanitation_2_v4.13

and I can confirm that the applied patches fix this bug (as well as #1438258).

Comment 4 Andrew Haveland-Robinson 2017-10-26 14:30:53 UTC
I can confirm the same screen corruption issue on an HP530 laptop since upgrading from 4.12.14-300.fc26.i686 which had no problem.

Issue still present in:
4.13.8-200.fc26.i686 in repo updates and
4.13.9-200.fc26.i686 in repo updates-testing (just installed now)

It appears the patch still hasn't made it into the repos yet, so will stick with 4.12.14-300 for the time being.

Comment 5 Alex Villacís Lasso 2017-11-22 12:35:38 UTC
Still hapenning under Fedora 27, with kernel-PAE-4.13.13-300.fc27.i686 and with the same symptoms. I am forced to keep and boot into kernel-PAE-4.12.14-300.fc26.i686 from Fedora 26 for just this reason.

Comment 6 Alex Villacís Lasso 2017-11-29 16:01:20 UTC
Still happening under kernel-PAE-4.13.15-300.fc27.i686 .

Comment 7 Andrew Haveland-Robinson 2017-12-04 18:53:17 UTC
and 4.13.16-302.fc27.i686

I didn't notice before as I can only ssh in, but keyboard and trackpad are also unresponsive on all kernels, and kernel errors are issued in ssh session on screen blank and awaken.
However, an external usb keyboard works and usb mouse moves the pointer ok above the corrupted screen, but otherwise the laptop is totally unusable except via ssh.

https://bugs.freedesktop.org/show_bug.cgi?id=102929 has some more info about this bug.

Comment 8 Andrew Haveland-Robinson 2017-12-11 11:13:30 UTC
Still not fixed in 4.14.3-300.fc27.i686 !
No trackpad or keyboard response, only external usb keyboard and mouse responds but screen corruption makes these unusable.
Really don't want to spend hours downgrading to fc26.

Comment 9 Alex Villacís Lasso 2018-02-19 16:16:25 UTC
With kernel 4.15.3-300.fc27.i686 this bug has been fixed. Thanks!