Bug 1500387 (CVE-2017-13721)

Summary: CVE-2017-13721 xorg-x11-server: Insufficient validation of shmseg resource id
Product: [Other] Security Response Reporter: Andrej Nemec <anemec>
Component: vulnerabilityAssignee: Red Hat Product Security <security-response-team>
Status: CLOSED WONTFIX QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: unspecifiedCC: airlied, ajax, alexl, bskeggs, caillon+fedoraproject, jglisse, mbarnes, ofourdan, rhughes, rstrode, sandmann, slawomir, xgl-maint
Target Milestone: ---Keywords: Security
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: xorg-x11-server 1.19.4 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-01 05:12:19 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1500389, 1910731    
Bug Blocks: 1500390    

Description Andrej Nemec 2017-10-10 13:25:47 UTC
In X.Org Server (aka xserver and xorg-server) before 1.19.4, an attacker authenticated to an X server with the X shared memory extension enabled can cause aborts of the X server or replace shared memory segments of other X clients in the same session.

References:

http://www.openwall.com/lists/oss-security/2017/10/04/10
https://lists.x.org/archives/xorg-announce/2017-October/002808.html

Upstream patch:

https://cgit.freedesktop.org/xorg/xserver/commit/?id=b95f25af141d33a65f6f821ea9c003f66a01e1f1

Comment 1 Andrej Nemec 2017-10-10 13:29:12 UTC
Created xorg-x11-server tracking bugs for this issue:

Affects: fedora-all [bug 1500389]