Bug 1502715

Summary: pcs : update of a vm resource with remote-node returns an abnormal error
Product: Red Hat Enterprise Linux 7 Reporter: Renaud Marigny <rmarigny>
Component: pcsAssignee: Ivan Devat <idevat>
Status: CLOSED ERRATA QA Contact: cluster-qe <cluster-qe>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 7.4CC: cfeist, cluster-maint, idevat, jherrman, jruemker, omular, rsteiger, sbradley, tojeline
Target Milestone: rcKeywords: ZStream
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: pcs-0.9.161-1.el7 Doc Type: Bug Fix
Doc Text:
Previously, attempting to use the "pcs resource update" command to change the "remote-node" attribute failed even if the target resource already had "remote-node" configured with the same value as the new one. This caused failures in a variety of Puppet operations that automatically update node information. Now, the pcs utility is capable of changing "remote-node" in the described circumstances, which prevents the problem from occurring.
Story Points: ---
Clone Of:
: 1507399 (view as bug list) Environment:
Last Closed: 2018-04-10 15:40:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1507399, 1522983    
Attachments:
Description Flags
proposed fix none

Comment 4 Ivan Devat 2017-10-17 08:01:05 UTC
Created attachment 1339614 [details]
proposed fix

Comment 8 Ivan Devat 2017-11-02 16:12:56 UTC
After Fix:

[ant ~] $ rpm -q pcs
pcs-0.9.161-1.el7.x86_64

[ant ~] $ pcs resource show R
 Resource: R (class=ocf provider=heartbeat type=Dummy)
  Meta Attrs: remote-node=cat
  Operations: migrate_from interval=0s timeout=20 (R-migrate_from-interval-0s)
              migrate_to interval=0s timeout=20 (R-migrate_to-interval-0s)
              monitor interval=10 timeout=20 (R-monitor-interval-10)
              reload interval=0s timeout=20 (R-reload-interval-0s)
              start interval=0s timeout=20 (R-start-interval-0s)
              stop interval=0s timeout=20 (R-stop-interval-0s)
[ant ~] $ pcs resource update R meta remote-node=cat
[ant ~] $ echo $?
0

Comment 14 errata-xmlrpc 2018-04-10 15:40:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0866