Bug 1502827

Summary: gnome-initial-setup 'user creation' mode no longer runs after install with no user account (since 3.26.1)
Product: [Fedora] Fedora Reporter: Adam Williamson <awilliam>
Component: gdmAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 27CC: alexl, caillon+fedoraproject, fmuellner, gmarr, gnome-sig, jbicha, john.j5live, mbarnes, mclasen, pwhalen, rhughes, rstrode, sandmann
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: AcceptedFreezeException
Fixed In Version: gdm-3.26.1-2.fc27 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-10-31 15:38:54 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 245418, 1396705, 1499170    

Description Adam Williamson 2017-10-16 19:40:08 UTC
This broke with Fedora-27-20171012.n.0, when GNOME 3.26.1 landed in Fedora 27. When you run a Workstation install without creating a user account in the installer, on boot, gnome-initial-setup should run in its 'user account creation' mode, allowing (in fact requiring) you to create a user account. However, it no longer does. On first boot after a Workstation install without a user account created, the system boots to GDM, displaying a 'Username:' prompt:

https://openqa.fedoraproject.org/tests/158599#step/_graphical_wait_login/8

This doesn't actually appear to violate the release criteria as written, but it is quite a bad bug, so nominating for a Final freeze exception.

Comment 1 Ray Strode [halfline] 2017-10-23 18:54:40 UTC
so i presume this is caused by this commit:

https://git.gnome.org/browse/gdm/commit/?id=1abdb

kernel_cmdline_initial_setup_argument is supposed to fail unless gnome.initial-setup is on the kernel command line, but I guess it must be succeeding?  I'm guessing openqa doesn't run with gdm debug enabled right? I'll probably just need to fire off an install, unless someone else already has journal with gdm debug enabled handy.

Comment 2 Ray Strode [halfline] 2017-10-23 18:58:21 UTC
oh i bet i know, i bet it's trying wayland and failing for whatever reason, and then falling back to X, but now already_done_initial_setup_on_this_boot succeeds.

Comment 3 Jeremy Bicha 2017-10-23 21:39:31 UTC
Ray, I think Pop!_OS had a similar problem as this bug (Initial Setup's new user mode not working with Wayland) and it was one reason they disabled Wayland for their 17.10 release.

Comment 4 Geoffrey Marr 2017-10-23 21:49:57 UTC
Discussed during the 2017-10-23 blocker review meeting: [1]

The decision to classify this bug as an AcceptedFreezeException was made as this cannot be fixed with an update.

[1] https://meetbot.fedoraproject.org/fedora-blocker-review/2017-10-23/f27-blocker-review.2017-10-23-16.00.txt

Comment 5 Adam Williamson 2017-10-23 21:58:45 UTC
Jeremy: Ray's theory is actually the opposite: that it works if Wayland does (or if the system is configured such that no attempt is made to run g-i-s under Wayland at all), but doesn't work if we hit a fallback from Wayland to X11, because the 'OK, we ran already' file gets written on the failed attempt to run it under Wayland, so when it's run again under X11, it decides it ran already and quits. As I understand his theory, anyhow.

Comment 6 Adam Williamson 2017-10-23 22:16:31 UTC
Ray posted a scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=22653424

in my testing, it looks like it fixes the bug. thanks.

Comment 7 Paul Whalen 2017-10-25 13:18:37 UTC
*** Bug 1505997 has been marked as a duplicate of this bug. ***

Comment 8 Paul Whalen 2017-10-25 13:20:37 UTC
This also affects the armhfp and aarch64 disk images, booting to gdm rather than gnome-initial-setup. Confirmed fixed with gdm-3.26.1-2.fc27.

Comment 9 Jens Petersen 2017-10-26 04:02:22 UTC
Is it going into Bodhi?

Comment 10 Jens Petersen 2017-10-26 04:03:19 UTC
Any test Live images available with this build yet?

Comment 11 Adam Williamson 2017-10-26 05:02:14 UTC
No, but you don't really need one. Just run an install from a recent live image, then do 'chroot /mnt/sysimage' and update the package after the install completes, before rebooting to the installed system.

Ray, can you submit an update with the fix? Thanks!

Comment 12 Ray Strode [halfline] 2017-10-26 16:58:17 UTC
╎rstrode@halfstation〉⎛/srv/sources/pkgs/gdm⎞ ⌜03:46 PM⌟
╎❯ fedpkg update
Password: 
================================================================================
     gdm-3.26.1-2.fc27
================================================================================
   Update ID: FEDORA-2017-2a7d1f7ebf
Content Type: rpm
     Release: Fedora 27
      Status: pending
        Type: bugfix
       Karma: 0
   Autokarma: True  [-3, 3]
     Request: testing
        Bugs: 1502827 - None
       Notes: make sure initial-setup starts when wayland fails
   Submitter: rstrode
   Submitted: 2017-10-26 16:57:38
    Comments: bodhi - 2017-10-26 16:57:38 (karma 0)
              This update has been submitted for testing by
              rstrode.

  https://bodhi.fedoraproject.org/updates/FEDORA-2017-2a7d1f7ebf

Comment 13 Fedora Update System 2017-10-31 15:38:54 UTC
gdm-3.26.1-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.