Bug 150311

Summary: Mouse pointer jumps when resizing window
Product: [Fedora] Fedora Reporter: August <fusionfive>
Component: metacityAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 3   
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-05-12 13:36:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description August 2005-03-04 16:17:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050224 Firefox/1.0.1 Fedora/1.0.1-1.3.1

Description of problem:
If I have a resizable non-maximized window that's aligned with the top of (or near the top of) the screen and I drag the top edge of the window to decrease its height, the mouse pointer jumps about one cm to the right just before the pointer shape turns into an up-down arrow.

Version-Release number of selected component (if applicable):
metacity-2.8.6-2

How reproducible:
Always

Steps to Reproduce:
1. Launch any application that has a resizable window, for instance gedit.

2. Make sure the window is not maximized and move it to the topmost position on the screen (as far up as possible).

3. Move the mouse pointer towards the top edge of the window until the pointer shape turns into an up-down arrow.


  

Actual Results:  The mouse pointer jumps about one cm to the right just before the pointer shape turns into an up-down arrow.

Expected Results:  No jump, continuous movement.

Additional info:

This happens with all window themes i have tried. My screen resolution is 800x600.

Comment 1 Marius Andreiana 2005-05-12 13:36:11 UTC

*** This bug has been marked as a duplicate of 150309 ***