Bug 150540

Summary: valgrind segfaults under xen
Product: [Fedora] Fedora Reporter: Robin Green <greenrd>
Component: xenAssignee: Rik van Riel <riel>
Status: CLOSED WONTFIX QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 3CC: sct
Target Milestone: ---   
Target Release: ---   
Hardware: athlon   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-24 15:10:04 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Robin Green 2005-03-07 22:04:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Running valgrind on a xen0-linux kernel produces consistent segfaults within fractions of a second of valgrind starting.

Version-Release number of selected component (if applicable):
xen-2-20050302

How reproducible:
Always

Steps to Reproduce:
1. Install xen-2-20050302 and kernel-xen0-2.6.11-1.1176_FC4
2. Reboot into xen
3. Run valgrind --tool=memcheck ls
  

Actual Results:  Valgrind shows a segfault in a random place in libc or /bin/ls. (Occassionally, ls completes successfully, but more often than not, it fails with a segfault.)

Expected Results:  No segfault

Additional info:

This bug does not occur running under 2.6.11-1.1176_FC4 (the equivalent non-xeno kernel).

Version of valgrind is valgrind-2.2.0-3
Version of coreutils is coreutils-5.2.1-31

I couldn't reproduce this bug in single-user mode with no services running. However, on the other hand, I could reproduce it consistently in runlevels 3 and 5, and whether xend was started made no difference.
Comment 1 Robin Green 2005-03-07 22:08:11 EST
This bug also doesn't occur under a xen-testing kernel that I built myself.
(However, I built that kernel as a monolithic kernel without lots of things that
the runlevel 3 services were expecting, so it was not really a 100% comparable
test.)
Comment 2 Stephen Tweedie 2006-01-24 18:21:53 EST
Does the problem persist in current FC5test2 or rawhide?  The Xen kernel and
hypervisor have been greatly rebased in that release.  Thanks!
Comment 3 Stephen Tweedie 2006-02-24 15:10:04 EST
Closing due to lack of reporter feedback; please reopen if you can reproduce on
current kernels.