Bug 1506205

Summary: [RFE] Add support for ' --repofrompath=<repoid>,<path/url>' flag to repotrack
Product: Red Hat Enterprise Linux 7 Reporter: afox <afox>
Component: yum-utilsAssignee: Michal Domonkos <mdomonko>
Status: CLOSED ERRATA QA Contact: Eva Mrakova <emrakova>
Severity: medium Docs Contact: Marie Dolezelova <mdolezel>
Priority: medium    
Version: 7.0CC: emrakova, james.antill, kabbott, mdomonko, packaging-team-maint, tbowling, vmukhame
Target Milestone: rcKeywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: yum-utils-1.1.31-50.el7 Doc Type: Release Note
Doc Text:
The "repotrack" command now supports the `--repofrompath` option The `--repofrompath option`, which is already supported by the "repoquery" and "repoclosure" commands, has been added to the "repotrack" command. As a result, non-root users can now add custom repositories to track without escalating their privileges.
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-10-30 11:40:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 1546815, 1549618    

Description afox@redhat.com 2017-10-25 11:54:23 UTC
1. Proposed title of this feature request  

Add support for ' --repofrompath=<repoid>,<path/url>' flag to repotrack
   
2. Who is the customer behind the request?  
Account: Citigroup (411070)
TAM customer: Yes
SRM customer: Yes
Strategic: Yes
  
3. What is the nature and description of the request?  

The 'repotrack' component from yum-utils accepts the "-r REPOID, --repoid=REPOID" flags but does not accept the ' --repofrompath=<repoid>,<path/url>' flag that repoquery and repoclosure accept.

It would be beneficial for repotrack to accept 'repofrompath' as well.
  
4. Why does the customer need this? (List the business requirements here)  

To allow downloading of packages not configured in /etc.

5. How would the customer like to achieve this? (List the functional requirements here)  

By simply adding the functionality already present in repoquery and repoclosure. 

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  

Simply use the parameter to download packages. 

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  

There is an implemented RFE for this feature against DNF. 
Bug id is 1113384.

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  

No.

9. Is the sales team involved in this request and do they have any additional input?  

No.

10. List any affected packages or components. 
 
yum
yum-utils

11. Would the customer be able to assist in testing this functionality if implemented?

Yes

Comment 20 errata-xmlrpc 2018-10-30 11:40:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3280