Bug 1506641

Summary: [RFE] Add support for configuring 'in-overcloud' resources for octavia through workflows and ansible
Product: Red Hat OpenStack Reporter: Brent Eagles <beagles>
Component: openstack-tripleo-commonAssignee: Or Idgar <oidgar>
Status: CLOSED WONTFIX QA Contact: Alexander Stafeyev <astafeye>
Severity: high Docs Contact:
Priority: high    
Version: 12.0 (Pike)CC: astafeye, ihrachys, jlibosva, mburns, nyechiel, oidgar, slinaber
Target Milestone: ---Keywords: FutureFeature, TechPreview, Triaged
Target Release: 12.0 (Pike)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1506643 1506644 (view as bug list) Environment:
Last Closed: 2017-12-06 14:09:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1433537, 1506643, 1506644, 1506647    

Description Brent Eagles 2017-10-26 13:34:28 UTC
Complete configuration of Octavia requires the creation of resources in the overcloud. This requires host configuration steps and openstack cloud operations on the overcloud glance, neutron and nova services. Running ansible from a mistral workflow seems to be a workable solution as it has the required integration with heat and allows host level commands to be run in a deterministic intuitive manner.

Comment 1 Ihar Hrachyshka 2017-11-07 19:06:41 UTC
Is this bug still on track for beta/ga?

Comment 2 Or Idgar 2017-11-08 07:14:10 UTC
Yes, RFE should be used for Octavia Tech Preview in OSP 12 hopefully

Comment 4 Nir Magnezi 2017-12-06 14:09:06 UTC
Pushed to OSP13, covered by bug 1506644