Bug 1506643

Summary: Add support for running octavia overcloud configuration from heat templates
Product: Red Hat OpenStack Reporter: Brent Eagles <beagles>
Component: openstack-tripleo-heat-templatesAssignee: Brent Eagles <beagles>
Status: CLOSED WONTFIX QA Contact: Gurenko Alex <agurenko>
Severity: high Docs Contact:
Priority: high    
Version: 12.0 (Pike)CC: jlibosva, mburns, rhel-osp-director-maint, sasha, slinaber
Target Milestone: ---Keywords: TechPreview, Triaged
Target Release: 12.0 (Pike)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1506641
: 1506647 (view as bug list) Environment:
Last Closed: 2017-12-06 14:14:24 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1506641, 1506644    
Bug Blocks: 1506647    

Description Brent Eagles 2017-10-26 13:36:09 UTC
+++ This bug was initially created as a clone of Bug #1506641 +++

Complete configuration of Octavia requires the creation of resources in the overcloud. This requires host configuration steps and openstack cloud operations on the overcloud glance, neutron and nova services. Running ansible from a mistral workflow seems to be a workable solution as it has the required integration with heat and allows host level commands to be run in a deterministic intuitive manner.

Comment 1 Brent Eagles 2017-10-26 13:37:54 UTC
Current u/s patch submitted to master (queens)
https://review.openstack.org/#/c/508195/

Comment 3 Nir Magnezi 2017-12-06 14:14:24 UTC
Pushed to OSP13, covered by bug 1506647