Bug 1507001

Summary: [FutureFeature]Import python-stestr for RHOS-13
Product: Red Hat OpenStack Reporter: Chandan Kumar <chkumar>
Component: python-stestrAssignee: Chandan Kumar <chkumar>
Status: CLOSED ERRATA QA Contact: Martin Kopec <mkopec>
Severity: unspecified Docs Contact:
Priority: high    
Version: 13.0 (Queens)CC: jjoyce, jschluet, markmc, mbracho, mburns, rhos-flags, srevivo, tvignaud
Target Milestone: betaKeywords: FutureFeature, Reopened, Triaged
Target Release: 13.0 (Queens)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: python-stestr-1.1.0-1.el7ost.1 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2018-06-27 13:38:59 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Chandan Kumar 2017-10-27 11:49:36 UTC
Tempest-17.1.0 is coming for RHOS-12 which adds python-stestr as a BR to run tempest unit tests. We need to import this package in RHOS-12 for the same.

Comment 1 Thierry Vignaud 2017-10-31 15:29:42 UTC
But python-stestr also needs python-future...

Comment 2 Mike Burns 2017-11-02 12:45:09 UTC
This is a build requires only, so we don't need to track in BZ.

Comment 3 Chandan Kumar 2018-01-09 12:12:59 UTC
Opening it as coming as a Requires for Tempest in Queens releases.
It is going the universal test runner for running unit, integration as well as functional tests

Comment 8 Martin Kopec 2018-04-24 12:18:44 UTC
python2-stestr-1.1.0-1.el7ost.1 package is available in RHOS13 repository, so marking the bug as VERIFIED.

Comment 11 errata-xmlrpc 2018-06-27 13:38:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086