Bug 1508383

Summary: repodata for debuginfo packages gets mirrored onto wrong directory
Product: [Fedora] Fedora Reporter: Juha Nikkanen <nikkej>
Component: mirrormanager2Assignee: Pierre-YvesChibon <pingou>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 26CC: adrian, infra-sig, jonstanley, kevin, pingou, puiterwijk
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-11-04 22:29:30 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Juha Nikkanen 2017-11-01 10:45:51 UTC
I found that updates by 30th of Oct does not have debuginfo packages which would have up to date content. Instead, they still exist from 23rd of Oct. While investigating further, it seems that repodata of debuginfo packages got into directory from where dnf and other package managers do not expect them to be. Below there is directory listings from ftp.funet.fi but for quick look this same phenomenon repeats on another mirrors as well. Also seems to affect Fedora 25.

For reference, updates repo repodata directory which is good:

Index of /pub/mirrors/fedora.redhat.com/pub/fedora/linux/updates/26/x86_64/repodata

 Icon   Name                                                  Last modified      Size  Description
 [DIR]  Parent Directory                                                        -
 [   ]  21cadb5f2ee7f037f...8f-primary.xml.gz                 30-Oct-2017 18:04  3.1M
 [   ]  63cff7903fddeae90...6e-primary.sqlite.bz2             30-Oct-2017 18:04  6.9M
 [   ]  282b0fdd6bd48baf6...0d-comps-Everything.x86_64.xml    30-Oct-2017 18:03  1.8M
 [   ]  95715c1618f07276b...9a-other.xml.gz                   30-Oct-2017 18:04  1.4M
 [   ]  373721a0d5be20ce4...f6-comps-Everything.x86_64.xml.gz 30-Oct-2017 18:04  443K
 [   ]  abbc90c416d9a5bcd...d2-updateinfo.xml.xz              30-Oct-2017 18:14  813K
 [   ]  ae67ff2628d300947...20-filelists.sqlite.bz2           30-Oct-2017 18:04   12M
 [   ]  de9f9748ba4cf2ba0...12-filelists.xml.gz               30-Oct-2017 18:04   12M
 [   ]  eabc77d8bd3004b61...9b-other.sqlite.bz2               30-Oct-2017 18:04  2.3M
 [   ]  repomd.xml                                            30-Oct-2017 18:14  4.3K
  
But then for debug infos:

Index of /pub/mirrors/fedora.redhat.com/pub/fedora/linux/updates/26/x86_64/debug/repodata

 Icon   Name                                       Last modified      Size  Description
 [DIR]  Parent Directory                                                -
 [DIR]  repodata/                                  01-Nov-2017 04:26    -
 [   ]  084314c0a9009d8f6...6b-primary.sqlite.xz   23-Oct-2017 19:44  365K
 [   ]  6c642cb77ee95f2df...aa-primary.xml.gz      23-Oct-2017 19:44  255K
 [   ]  724d1785d9f915c0a...39-other.sqlite.xz     23-Oct-2017 19:44  392K
 [   ]  873fe6487cd08c3f3...05-other.xml.gz        23-Oct-2017 19:44  421K
 [   ]  919a1614dba6ebc70...87-filelists.xml.gz    23-Oct-2017 19:44  4.6M
 [   ]  fe6afa8f63cdc34b2...0a-filelists.sqlite.xz 23-Oct-2017 19:44  4.2M
 [   ]  repomd.xml                                 23-Oct-2017 19:44  3.0K
  
There's another repodata directory which, according to timestaps, it's content seems to be up to date:

Index of /pub/mirrors/fedora.redhat.com/pub/fedora/linux/updates/26/x86_64/debug/repodata/repodata

 Icon   Name                                        Last modified      Size  Description
 [DIR]  Parent Directory                                              -
 [   ]  5bc9832d4b459be1c...f1-filelists.sqlite.bz2 30-Oct-2017 18:04  7.3M
 [   ]  6b44e1cff0c90f911...cb-other.xml.gz         30-Oct-2017 18:04  495K
 [   ]  75e587ba103c7a543...51-primary.sqlite.bz2   30-Oct-2017 18:04  675K
 [   ]  4263b02530dc946db...66-primary.xml.gz       30-Oct-2017 18:04  350K
 [   ]  a011a04fe40bc7dc9...17-filelists.xml.gz     30-Oct-2017 18:04  7.2M
 [   ]  e656a7cbd5e864a66...28-other.sqlite.bz2     30-Oct-2017 18:04  673K
 [   ]  repomd.xml                                  30-Oct-2017 18:04  3.0K

Comment 1 Kevin Fenzi 2017-11-04 22:29:30 UTC
This was an error in our sync scripts... should be fixed as each updates branch is pushed out today.