Bug 151193

Summary: OpenSSH 4.0p1 released
Product: [Fedora] Fedora Reporter: Robert Scheck <redhat-bugzilla>
Component: opensshAssignee: Tomas Mraz <tmraz>
Status: CLOSED RAWHIDE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: rawhide   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 4.0p1-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2005-03-26 18:38:43 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
openssh-4.0p1-redhat.patch
none
openssh-4.0p1-vendor.patch none

Description Robert Scheck 2005-03-15 17:16:03 EST
Description of problem:
OpenSSH 4.0p1 released, while Fedora Core Development has only 3.9p1.

Version-Release number of selected component (if applicable):
openssh-3.9p1-12

Actual results:
You've to remove the accs code again - unpack openssh-3.9p1-
noacss.tar.gz and openssh-3.9p1.tar.gz; diff them and do some actions 
to get the same result at openssh-4.0p1 vs. openssh-4.0p1-noacss.

Some patch merging is also needed, at Patch0 and Patch4. My merged
patches are attached.

Expected results:
Upgrade to 4.0p1 ;-)
Comment 1 Robert Scheck 2005-03-15 17:18:16 EST
Created attachment 112038 [details]
openssh-4.0p1-redhat.patch
Comment 2 Robert Scheck 2005-03-15 17:18:57 EST
Created attachment 112039 [details]
openssh-4.0p1-vendor.patch
Comment 3 Tomas Mraz 2005-03-16 04:27:59 EST
Nice, but I've actually worked yesterday on the same thing ;-)

I want to wait a few days before building it in Rawhide whether some fatal bugs
 appear or not.
Comment 4 Robert Scheck 2005-03-16 04:38:05 EST
Oh, the onliest larger change, I got yesterday was, that you've got to write:
  ListenAddress [2001:1234:5678::1]
now rather the old
  ListenAddress 2001:1234:5678::1
style in 3.x or 4.0p1 will fail at a restart but it doesn't kill the SSH session 
(because of the Red Hat safe-stop-start patch, I think).
Comment 5 Robert Scheck 2005-03-23 10:33:19 EST
4.0p1 works fine here since ~ 10 days.
Comment 6 Robert Scheck 2005-03-26 18:38:43 EST
Thanks for rebuilding in Rawhide, closing now.