Bug 1515084

Summary: Volumes don't show up in "volume status' widget in Tendrl-Gluster-at-a-Glance
Product: Red Hat Gluster Storage Reporter: Rochelle <rallan>
Component: web-admin-tendrl-uiAssignee: Nishanth Thomas <nthomas>
Status: CLOSED ERRATA QA Contact: Rochelle <rallan>
Severity: high Docs Contact:
Priority: unspecified    
Version: rhgs-3.3CC: ppenicka, rhinduja, rhs-bugs, sankarshan
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: tendrl-gluster-integration-1.5.4-4.el7rhgs.noarch.rpm Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-12-18 04:37:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
Volumes under "volume status" are reflected correctly on the Grafana dashboard none

Description Rochelle 2017-11-20 06:27:15 UTC
Description of problem:
=======================
Under "status" in "Tendrl-Gluster-at-a-glance", with respect to geo-replication, the slave volume was seen but with respect to the the master cluster, which had 2 volumes, neither of them came up under "volume status" widget even after 45 min but brick status and host status was shown.


Version-Release number of selected component (if applicable):
=============================================================
tendrl-ui-1.5.4-3.el7rhgs.noarch



Actual results:
===============
There was nothing under "volume status"



Expected results:
==================
The volume status should be seen as 2 volumes which were created

Comment 2 Petr Penicka 2017-11-20 13:26:12 UTC
Giving pm_ack and 3.3.z+ since both qa_ack and dev_ack are already given.

Comment 4 Rochelle 2017-11-22 08:57:53 UTC
Created attachment 1357299 [details]
Volumes under "volume status" are reflected correctly on the Grafana dashboard

Created 3 volumes and this was correctly reflected under "volume status" on the home tab as well as the "Tendrl-at-a-Glance" tab on the Grafana dashboard.

Moving this bug to verified.

Comment 7 errata-xmlrpc 2017-12-18 04:37:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478